[Aries KK][NFC] URL can't be shared via NFC.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: yelanying, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8675598 [details]
logcat_1649.txt

[1.Description]:
[Aries KK v2.5][NFC] Enable NFC and launch brower app. You will find URL can't be shared via NFC.
Time: 16:49
See attachments: logcat_1649.txt and Aries_KK v2.5.3gp

[2.Testing Steps]: 
Precondition: Enable NFC 
1.Launch broswer app.
2.Navigate on a webpage.
3.Tap 2 devices to share URL via NFC .


[3.Expected Result]: 
3.Show shrinking UI.

[4.Actual Result]: 
3.No shrinking UI.

[5.Reproduction build]: 
Aries KK v2.5(Affected)
Build ID               20151018193102
Gaia Revision          f75a7e01912cee313fed92ff2089586f507b2ba5
Gaia Date              2015-10-16 13:00:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d1a89632277fbaaf470c90a35573776048988f2d
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151018.185054
Firmware Date          Sun Oct 18 18:51:02 UTC 2015
Bootloader             s1

Flame KK v2.5(Unaffected)
Build ID               20151018150205
Gaia Revision          f75a7e01912cee313fed92ff2089586f507b2ba5
Gaia Date              2015-10-16 13:00:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d1a89632277fbaaf470c90a35573776048988f2d
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151018.183443
Firmware Date          Sun Oct 18 18:34:55 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Flame KK v2.2(Unaffected)
Build ID               20151018032506
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9b9aad4197d9
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151018.070512
Firmware Date          Sun Oct 18 07:05:24 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
 16824
(Reporter)

Comment 1

3 years ago
Created attachment 8675600 [details]
Aries_KK v2.5.3gp
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected

Updated

3 years ago
QA Whiteboard: [COM=NFC]

Comment 2

3 years ago
[Blocking Requested - why for this release]:
regression issue
blocking-b2g: --- → 2.5?
Keywords: regression, regressionwindow-wanted

Comment 3

3 years ago
I tried with the latest aries build but unable to reproduce this issue.

[Aries]
Build ID               20151019205841
Gaia Revision          a87f947366c2e044bd6336e1982419ac45378969
Gaia Date              2015-10-19 15:22:08
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9605da94e75d61598d3c00f01a12d1b6bc427a6c
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151019.201730
Firmware Date          Mon Oct 19 20:17:38 UTC 2015
Bootloader             s1

Hi Jessica,
Could you please try with the latest build again? Or provide more detail reproduce steps? Thank you.
blocking-b2g: 2.5? → ---
Flags: needinfo?(yelanying)
Keywords: regression, regressionwindow-wanted
Please also help to enable NFC log in developers menu.
(Reporter)

Comment 5

3 years ago
Hi Alison and Yoshi,

I have tried again, and this issue can't reproduce on the latest two days' Aries KK v2.5.


Device: Aries KK v2.5 
Build ID               20151022003511
Gaia Revision          1b902ff26547e2a6c896351a6a73b673f65e19b2
Gaia Date              2015-10-21 14:56:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/daa7d98525e859d32a3b3e97101e129a897192a1
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151021.235445
Firmware Date          Wed Oct 21 23:54:53 UTC 2015
Bootloader             s1

Device: Aries KK v2.5 
Build ID               20151023005002
Gaia Revision          29ce8ec8606e59f582375234440812b046346513
Gaia Date              2015-10-22 05:31:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1f03a14106e59280761ac53904340f389674337f
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151023.001128
Firmware Date          Fri Oct 23 00:11:35 UTC 2015
Bootloader             s1
Flags: needinfo?(yelanying)
(Reporter)

Updated

3 years ago
QA Whiteboard: [COM=NFC] → [COM=NFC], [MGSEI-Triage+]

Comment 6

3 years ago
Thanks! According to comment 5, let's close this issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.