[New Homescreen] Modifying the icon of a pinned site allows rocketbar can expand and collapse

VERIFIED FIXED

Status

P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: enrico.ghiorzi, Assigned: cwiiis)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151015151621

Steps to reproduce:

Go on a website and pin it. Return to homescreen, an icon for the pinned site has been created. Drag it over the "…" area at the buttom of the screen to modify the pinned icon. Give it a new name and return to homescreen.


Actual results:

The icon of the pinned website has been replaced with the generic gray spaceship icon.

The "Search or enter address" bar is now collapsible.

When the "Search or enter address" bar is not collapsed, the bar with the "delete" and "…" options for managing the icons is misplaced (too low).


Expected results:

The icon of the pinned website should retein its icon.

The "Search or enter address" bar should remain fixed.

The bar with the "delete" and "…" options for managing the icons should always be placed properly.
(Reporter)

Comment 1

3 years ago
This issue was found on the following device/build

Build ID               20151019030208
Gaia Revision          f75bd584aca0a751a5bed115800250faa8412927
Gaia Date              2015-10-19 06:39:58
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1a157155a4fe0074b3d03b54fe9e466472c2cd56
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150527.043015
Firmware Date          Wed May 27 04:30:24 EDT 2015
Bootloader             L1TC000118D0
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
Whiteboard: [systemsfe]
Depends on: 1216093
blocking-b2g: 2.5? → 2.5+
Lets re-test once 1216093 lands.
Priority: -- → P2
(Reporter)

Updated

3 years ago
Depends on: 1216106
(Reporter)

Comment 4

3 years ago
Not sure whether bug 1216106 is a dependency or a duplicate.
Let's make it a duplicate, and use this bug to track it since it has more information.
Status: UNCONFIRMED → NEW
No longer depends on: 1216106
Ever confirmed: true
Summary: [New Homescreen] Modifying the icon of a pinned site on new Gaia homescreen breaks the homescreen → [New Homescreen] Modifying the icon of a pinned site allows rocketbar can expand and collapse
Duplicate of this bug: 1216106
(Assignee)

Comment 7

3 years ago
Interestingly (for certain values of interesting), this bug only manifests when you actually make a change - cancelling out of the dialog with no changes has no ill effects. This seems to point to a bug in homescreen in responding to the event I think, but can't say for sure just yet.
(Assignee)

Comment 8

3 years ago
I take it back, removing the event handler has no effect. I think this may be caused by the toast animating in from the bottom of the screen.
(Assignee)

Comment 9

3 years ago
Can confirm, removing the message that gets posted in response to the bookmark-editing activity in system fixes this problem. Just need to track down the style and such to fix this properly...
(Assignee)

Comment 10

3 years ago
I think this might be a problem of a popup's size changes being treated as if they came from the browser frame when they didn't. Still debugging.
(Assignee)

Comment 11

3 years ago
Found it, patch + test incoming...
(Assignee)

Updated

3 years ago
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Created attachment 8676322 [details] [review]
[gaia] Cwiiis:bug1216129-subwindows-causing-collapsing > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8676322 - Flags: review?(etienne)
Comment on attachment 8676322 [details] [review]
[gaia] Cwiiis:bug1216129-subwindows-causing-collapsing > mozilla-b2g:master

r=me with a tiny comment!
Attachment #8676322 - Flags: review?(etienne) → review+
(Assignee)

Comment 14

3 years ago
Cheers, merged: https://github.com/mozilla-b2g/gaia/commit/40f8c06706c33a8c864e9d1778e58657b47abd2e
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
QA Whiteboard: [COM=Pin the Web]

Comment 15

3 years ago
Verified on 

[Flame]
Build ID               20151021065025
Gaia Revision          32d827a70af90a05918f234e5b16b35d5d2a07e8
Gaia Date              2015-10-20 20:57:29
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/473aefe5bd85842eeb142e0cde8e2cd21edbf40b
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151021.104033
Firmware Date          Wed Oct 21 10:40:46 EDT 2015
Bootloader             L1TC000118D0

[Aries]
Build ID               20151022003511
Gaia Revision          1b902ff26547e2a6c896351a6a73b673f65e19b2
Gaia Date              2015-10-21 14:56:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/daa7d98525e859d32a3b3e97101e129a897192a1
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151021.235445
Firmware Date          Wed Oct 21 23:54:53 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.