New options page is unreadable with some color settings

RESOLVED DUPLICATE of bug 1207084

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 1207084
2 years ago
2 years ago

People

(Reporter: ejlddll, Unassigned)

Tracking

41 Branch
Unspecified
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8675676 [details]
Screenshot of unreadable Options screen (Firefox 41.0.1, Windows)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33.1
Build ID: 20150625235107

Steps to reproduce:

Open Options in Firefox 41.0.1 (or later, I assume) with the following settings already in place under Options -> Content -> Colors:  white text, black or dark background, "Override the colors specified by the page with my selections above" -> Always


Actual results:

The main area of the Options page is displayed with white text on a white background, which is unreadable.



Expected results:

Optimal result:  the Options page should respect the settings given and style itself with white text on a dark background.

OR

Acceptable result:  the Options page overrides the text color *and* the background color to produce a combination of colors with enough contrast to be readable.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7

Comment 1

2 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
20151014143721

Reproducible.

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
20151015151621

Works for me. Probably fixed by bug 1207084.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1207084
You need to log in before you can comment on or make changes to this bug.