Closed Bug 1216288 Opened 4 years ago Closed 4 years ago

54,500 instances of "Remote iframe not rendered" emitted from layout/ipc/RenderFrameParent.cpp during linux64 debug testing

Categories

(Core :: Layout, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla45
Tracking Status
e10s + ---
firefox44 --- affected
firefox45 --- fixed

People

(Reporter: erahm, Assigned: mattwoodrow)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

This is by far the most verbose warning during testing. The regression seems to have happened in the past week or so and is isolated to e10s tests.

> 54548 [NNNNN] WARNING: Remote iframe not rendered: file layout/ipc/RenderFrameParent.cpp, line 391

This warning [1], introduced in bug 788322, shows up in the following test suites:

> mozilla-central_ubuntu32_vm-debug_test-mochitest-e10s-browser-chrome-7-bm01-tests1-linux32-build22.txt:6151
> mozilla-central_ubuntu32_vm-debug_test-web-platform-tests-e10s-3-bm01-tests1-linux32-build7.txt:5708
> mozilla-central_ubuntu32_vm-debug_test-web-platform-tests-e10s-1-bm08-tests1-linux32-build12.txt:5272
> mozilla-central_ubuntu32_vm-debug_test-web-platform-tests-e10s-6-bm03-tests1-linux32-build7.txt:5040
> mozilla-central_ubuntu32_vm-debug_test-web-platform-tests-e10s-8-bm01-tests1-linux32-build2.txt:4429
> mozilla-central_ubuntu32_vm-debug_test-web-platform-tests-e10s-7-bm03-tests1-linux32-build3.txt:4227
> mozilla-central_ubuntu32_vm-debug_test-web-platform-tests-e10s-2-bm01-tests1-linux32-build12.txt:4085
> mozilla-central_ubuntu32_vm-debug_test-web-platform-tests-e10s-4-bm03-tests1-linux32-build4.txt:3871
> mozilla-central_ubuntu32_vm-debug_test-mochitest-e10s-browser-chrome-6-bm08-tests1-linux32-build14.txt:3220
> mozilla-central_ubuntu32_vm-debug_test-mochitest-e10s-browser-chrome-2-bm01-tests1-linux32-build11.txt:3090
> mozilla-central_ubuntu32_vm-debug_test-mochitest-e10s-browser-chrome-1-bm01-tests1-linux32-build198.txt:1681
> mozilla-central_ubuntu32_vm-debug_test-mochitest-e10s-browser-chrome-3-bm01-tests1-linux32-build3.txt:1672
> mozilla-central_ubuntu32_vm-debug_test-mochitest-e10s-browser-chrome-5-bm08-tests1-linux32-build19.txt:1554
> mozilla-central_ubuntu32_vm-debug_test-web-platform-tests-e10s-5-bm01-tests1-linux32-build3.txt:1552
> mozilla-central_ubuntu32_vm-debug_test-mochitest-e10s-browser-chrome-4-bm02-tests1-linux32-build31.txt:1532
> mozilla-central_ubuntu32_vm-debug_test-mochitest-e10s-1-bm08-tests1-linux32-build5.txt:572
> mozilla-central_ubuntu32_vm-debug_test-mochitest-e10s-5-bm06-tests1-linux32-build105.txt:296
> mozilla-central_ubuntu32_vm-debug_test-mochitest-e10s-2-bm08-tests1-linux32-build4.txt:277
> mozilla-central_ubuntu32_vm-debug_test-mochitest-e10s-3-bm06-tests1-linux32-build97.txt:232
> mozilla-central_ubuntu32_vm-debug_test-mochitest-e10s-4-bm03-tests1-linux32-build228.txt:85
> mozilla-central_ubuntu32_vm-debug_test-mochitest-5-bm01-tests1-linux32-build76.txt:20

It shows up in     6231 tests. A few of the most prevalent:

> 360 - browser/components/sessionstore/test/browser_522545.js
> 269 - browser/base/content/test/general/browser_bug553455.js
> 243 - browser/components/sessionstore/test/browser_615394-SSWindowState_events.js
> 219 - browser/components/sessionstore/test/browser_crashedTabs.js
> 201 - browser/base/content/test/general/browser_pageInfo.js
> 173 - browser/components/sessionstore/test/browser_600545.js
> 172 - browser/components/sessionstore/test/browser_586068-browser_state_interrupted.js
> 152 - dom/html/test/browser_bug1108547.js
> 147 - browser/base/content/test/general/browser_bug561636.js
> 145 - browser/base/content/test/general/browser_aboutTabCrashed.js

[1] https://hg.mozilla.org/mozilla-central/annotate/1a157155a4fe0074b3d03b54fe9e466472c2cd56/layout/ipc/RenderFrameParent.cpp#l391
Regression appeared on 10/15 in this merge to m-c: https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=e193b4da0a8c
hg bisect points to cset 9935002f3e69, which landed w/ bug 1211654.

repro step on linux64:

> ./mach mochitest --e10s browser/components/sessionstore/test/browser_522545.js | grep 'Remote iframe not rendered'
Depends on: 1211654
Flags: needinfo?(matt.woodrow)
Keywords: regression
This isn't really a problem, we could probably just get rid of the warning.

I can try write a patch to silence just this case and catch others, but I won't have time this week.
Flags: needinfo?(matt.woodrow)
(In reply to Matt Woodrow (:mattwoodrow) from comment #3)
> This isn't really a problem, we could probably just get rid of the warning.
> 
> I can try write a patch to silence just this case and catch others, but I
> won't have time this week.

If the warning isn't useful we should just remove it, if it's helpful in some cases I guess going a more elaborate route makes sense.
Assignee: nobody → matt.woodrow
This continues to be the most verbose warning during testing by a factor of at least 10.
Attachment #8682311 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/0dc3d2925d7f
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
removing the b2g 2.5 flag since this commit has been reverted due to an incorrect merge, sorry for the confusion
You need to log in before you can comment on or make changes to this bug.