search_plugin.cgi in 4.0 displays array address instead of string

RESOLVED INVALID

Status

()

Bugzilla
Bugzilla-General
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Tom Iacono, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20151014143721

Steps to reproduce:

Our Bugzilla 4.0.1 system was working with Windows Server 2003, MySQL and 13 databases. A hardware problem caused havoc. We had to update to Windows Server 2012, Apache to 2.4. Reinstall MySQL, Bugzilla and associated modules. The system backup did not have all of the necessary support files. 

We can access the databases and create bugs. 



Actual results:

What we cannot do is search correctly. 

When searching: 
All Open or All Closed, the search parameters are ARRAY (0x) instead of strings and no bugs are returned. 
All All returns the entire database list that can be sorted as needed. 
Quicksearch of a bug by a number works. 

Apache24 error.log:
CGI.pm: defined(@array) is deprecated at lib/CGI.pm line 528.\r: C:/path/bugzilla/index.cgi, referer: http://xxxx/yyyy/
\t(Maybe you should just omit the defined()?)\r: C:/path/bugzilla/index.cgi, referer: http://xxxx/yyyy/

Apache24 access.log
"GET /search_plugin.cgi HTTP/1.1" 404 215

What am I missing. Language problem? Conversion? Perl module?


Expected results:

Search returns a bug list filtered by the search parameters.

This is a live system and formatted search results are needed for audit and tracking  purposes.
(Reporter)

Updated

2 years ago
Severity: normal → critical
OS: Unspecified → Windows
Priority: -- → P1
Hardware: Unspecified → x86_64
Severity: critical → normal

Comment 1

2 years ago
Bugzilla 4.0 support ended when Bugzilla 5.0 was released.
In your own interest, please upgrade to a supported version.

For support requests, please refer to http://www.bugzilla.org/support/ - Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Priority: P1 → --
Resolution: --- → INVALID
Summary: search_plugin.cgi displays array address instead of string → search_plugin.cgi in 4.0 displays array address instead of string
(Reporter)

Comment 2

2 years ago
I know that this is not a "bugzilla" problem. This is a plea for a debug direction. The data is in an incorrect format. I assume that the address is correct just the formatting is wrong. In C this is just one misplaced use of address or the data at the address. Where would this be specified for bugzilla? 

To update requires higher levels of MySQL and Bugzilla as well as 13 databases to be converted and customized.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

2 years ago
(In reply to Tom Iacono from comment #2)
> I know that this is not a "bugzilla" problem. This is a plea for a debug direction.

I provided that in the previous comment:
"For support requests, please refer to http://www.bugzilla.org/support/ - Thanks!"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.