Page Info should show ALT attributes for images in Media tab

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: dan, Assigned: db48x)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

17 years ago
One more nit to pick with the otherwise excellent new Page Info feature (as of
build 2002012403):

The ALT attribute for an image ought to be one of the fields shown, as it was in
the old Page Info feature.  The new one shows the TITLE and LONGDESC (still,
alas, underutilized by Web developers), but omits the ALT (which is more often
used).

Comment 1

17 years ago
Agreed.  Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
->db48x (Page Info)
Assignee: blaker → db48x
mass moving open bugs pertaining to page info to pmac@netscape.com as qa contact.

to find all bugspam pertaining to this, set your search string to
"BigBlueDestinyIsHere".
QA Contact: sairuh → pmac
(Assignee)

Comment 4

17 years ago
it's definatly doable. let me look at see if I can remeber why I didn't include
it in the first place.
(Assignee)

Updated

17 years ago
Blocks: 82059
(Assignee)

Comment 5

17 years ago
Created attachment 66504 [details] [diff] [review]
add alt text
Comment on attachment 66504 [details] [diff] [review]
add alt text

r=bzbarsky
Attachment #66504 - Flags: review+
(Assignee)

Comment 7

17 years ago
Created attachment 66509 [details] [diff] [review]
correctly finds alt text for objects
(Assignee)

Comment 8

17 years ago
Created attachment 66510 [details] [diff] [review]
correctly finds alt text for objects
Attachment #66504 - Attachment is obsolete: true
(Assignee)

Comment 9

17 years ago
Comment on attachment 66509 [details] [diff] [review]
correctly finds alt text for objects

blah. I hit submit too many times or something
Attachment #66509 - Attachment is obsolete: true
Comment on attachment 66510 [details] [diff] [review]
correctly finds alt text for objects

Right.	Good point on objects.

r=bzbarsky
Attachment #66510 - Flags: review+
(Assignee)

Comment 11

17 years ago
Created attachment 66561 [details] [diff] [review]
fix strict js warning
Attachment #66510 - Attachment is obsolete: true
Comment on attachment 66561 [details] [diff] [review]
fix strict js warning

Um. Rigth.  I shouldn't have missed that....
Attachment #66561 - Flags: review+
(Assignee)

Comment 13

17 years ago
jag, could you look at this for sr= please?
Status: NEW → ASSIGNED

Updated

17 years ago
Component: XP Apps: GUI Features → Page Info

Comment 14

17 years ago
*** Bug 123637 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
Uhm.. I've always used Mozilla's "page info" to check for ALT text in images and
add it the missing places. Sorry for the spam, but this seems to have been
forgotten (as is it have been already done and ready to be checked in for a
month now).

Comment 16

17 years ago
Comment on attachment 66561 [details] [diff] [review]
fix strict js warning

sr=jag
Attachment #66561 - Flags: superreview+
drivers say, "not critical for 0.9.9, ask for 1.0 approval once 0.9.9 is out"

Comment 18

17 years ago
*** Bug 129277 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
Comment on attachment 66561 [details] [diff] [review]
fix strict js warning

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #66561 - Flags: approval+
checked in on the trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 21

17 years ago
Well it would be nice to also have the ability to list ALT attributes in a
column in the list, by clicking on the "column button". As you could do in the
old PageInfo. Currently the only options available are "no.", "Address" and "Type".
(Assignee)

Comment 22

17 years ago
There isn't room for an alt tag of the proper length in the outliner. Rember,
the contents of the alt tag are supposed to be whatever text is neccessary to
replace the image, so it when used correctly it'll be a sentace or two at the
least. Much better suited to the preview area than a column in the outliner.

Comment 23

17 years ago
It was there before, and it was useful. I used it to quickly ensure that pages
has all ALT texts. For me, the current view-info is lesss useful than the old.. =/.
You could take the first N characters and add '...', and put the whole value in
a tooltip.

Comment 24

17 years ago
Yes but the "Address" content is often too long as well.
I didn't believe ALT properties were usually longer than a "Advertisement from
'Company'", as opposed to the LONGDESC, but I guess you're right about how it
_should_ be used.
Nevertheless, it's a fact that many users need to use this as a makeshift at
webplaces that use the ALT property wrong. And so it would far more convenient
to be able to scroll the outliner in order to find where there _are_ ALT
properties, instead of having to scroll each single entry in order to find the
right images.

Comment 25

17 years ago
I have filed bug 158245 and posted a patch that adds the "alt" attribute of
images to the <tree> in the media tab.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.