Closed Bug 1216357 Opened 6 years ago Closed 6 years ago

[New Homescreen] Apps dragged to the top of the home screen are moved to the bottom of the home screen

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-master verified)

VERIFIED FIXED
FxOS-S10 (30Oct)
blocking-b2g 2.5+
Tracking Status
b2g-master --- verified

People

(Reporter: KTucker, Assigned: cwiiis)

References

()

Details

(Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe])

Attachments

(3 files)

If the user drags an app above the top row of apps on the homescreen, the app will be dropped to the bottom of the home screen. 

Prerequisite: The device is on the new home screen.

Repro Steps:
1) Update a Aries to 20151019104907
2) Press and hold your finger on an app on the home screen that is not on the top row.
3) Drap the app above the top row of apps on the home screen and release.
4) Scroll down to the bottom of the home screen.

Actual:
The app will be moved to the bottom of the homescreen.

Expected:
The app returns to its original position or a new row above the top row of apps is created.

Environmental Variables:
Device: Aries 2.5
Build ID: 20151019104907
Gaia: f75bd584aca0a751a5bed115800250faa8412927
Gecko: d3e87bb40753327550143ba8ac8ee27b300cd4a9
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 5/5 100%
See attached: video clip, logcat
Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe]
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
This issue also occurs on Flame 2.5

The app is moved to the bottom of the home screen when dropped above the top row of apps.

Device: Flame 2.5 (Full FLash)(KK)(319mb)
Build ID: 20151019030208
Gaia: f75bd584aca0a751a5bed115800250faa8412927
Gecko: 1a157155a4fe0074b3d03b54fe9e466472c2cd56
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

----------

New homescreen is not available in 2.2.
[Blocking Requested - why for this release]: Obvious broken behaviour.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
blocking-b2g: --- → 2.5?
Well I was going to ni Chris on this but he beat me to the punch.  I agree that this issue is a blocker.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
blocking-b2g: 2.5? → 2.5+
Priority: -- → P3
Attachment #8676806 - Flags: review?(gmarty)
Comment on attachment 8676806 [details] [review]
[gaia] Cwiiis:bug1216357-homescreen-drop-at-beginning > mozilla-b2g:master

Looks good to me!
Attachment #8676806 - Flags: review?(gmarty) → review+
Just re-pushed (no tests ran due to broken infra at the time) - adding checkin-needed to merge after tests pass.
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/6ef605c10cdc15b4e20ccd16d7ed9faade96d43f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S10 (30Oct)
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: When dragging the app icon to the top of the homescreen, the app returns to new row above the top row of apps.
See attachment: verified_Flame_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20151022150207
Gaia Revision          29ce8ec8606e59f582375234440812b046346513
Gaia Date              2015-10-22 05:31:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/76bd0c01d72e64ca4f261ffdb2652a91f961e930
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151022.185000
Firmware Date          Thu Oct 22 18:50:13 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20151023005002
Gaia Revision          29ce8ec8606e59f582375234440812b046346513
Gaia Date              2015-10-22 05:31:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1f03a14106e59280761ac53904340f389674337f
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151023.001128
Firmware Date          Fri Oct 23 00:11:35 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.