Closed Bug 1216525 Opened 7 years ago Closed 7 years ago

The screen remains turned on if you receive a notification while being on a call

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

RESOLVED DUPLICATE of bug 1207221
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: jlorenzo, Unassigned)

References

()

Details

(Keywords: foxfood)

Steps to reproduce
1. Make a call.
2. Put you ear near the proximity sensor, so the screen turns off
3. Receive a notification (like an SMS or a calendar reminder)

Expected results
The screen turns on for a few seconds, so you can notice that you have a notification. After it turns off again, so your ear doesn't inadvertently tap at some random places of on the screen

Actual results
The screen remains on, leaving your ear/cheek the pleasure to dismiss the callscreen, turning on the speakerphone, or muting your own voice. See video for details: https://goo.gl/qJ8qBU

Build info
The problem is spotted on master[1], 2.2[2], and 2.1[1]

[1] Build ID               20151019205841
Gaia Revision          a87f947366c2e044bd6336e1982419ac45378969
Gaia Date              2015-10-19 15:22:08
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9605da94e75d61598d3c00f01a12d1b6bc427a6c
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151019.201730
Firmware Date          Mon Oct 19 20:17:38 UTC 2015
Bootloader             s1

[2] Build ID               20151020032711
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/6b4e563acaf9
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151020.070041
Firmware Date          Tue Oct 20 07:00:52 EDT 2015
Bootloader             L1TC000118D0

[3] Build ID               20150724001207
Gaia Revision          9dba58d18006e921546cec62c76074ce81e16518
Gaia Date              2015-07-23 12:36:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/41e10c6740be
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150724.035255
Firmware Date          Fri Jul 24 03:53:06 EDT 2015
Bootloader             L1TC000118D0
[Tracking Requested - why for this release]: Even though we lived with this issue for at least 3 releases, this scenario can happen to real users, without them being aware of what's happening.
We wouldn't have this issue if UX agreed to my fix for bug 1207221. The phone would stay off in this scenario and we would just vibrate to inform the user that something happened.
See Also: → 1207221
Based on bug 1207221 comment 0, that's a duplicate.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
See Also: 1207221
You need to log in before you can comment on or make changes to this bug.