osx 10.10.5 - devtools/client/webaudioeditor/test/browser_wa_properties-view-media-nodes.js | Test timed out

RESOLVED FIXED in Firefox 45, Firefox OS v2.5

Status

RESOLVED FIXED
3 years ago
4 months ago

People

(Reporter: jmaher, Assigned: jsantell)

Tracking

unspecified
Firefox 45

Firefox Tracking Flags

(firefox45 fixed, b2g-v2.5 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
this test fails in both opt and debug:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f57ad0d4fd2a

here is a snippet from the log:
10:51:52     INFO -  403 INFO TEST-START | devtools/client/webaudioeditor/test/browser_wa_properties-view-media-nodes.js
10:51:52     INFO -  ++DOCSHELL 0x11d3ba500 == 13 [pid = 1760] [id = 127]
10:51:52     INFO -  ++DOMWINDOW == 30 (0x111c92000) [pid = 1760] [serial = 336] [outer = 0x0]
10:51:52     INFO -  ++DOMWINDOW == 31 (0x1123bb000) [pid = 1760] [serial = 337] [outer = 0x111c92000]
10:51:52     INFO -  ++DOMWINDOW == 32 (0x113764400) [pid = 1760] [serial = 338] [outer = 0x111c92000]
10:51:52     INFO -  ++DOCSHELL 0x11f52a100 == 14 [pid = 1760] [id = 128]
10:51:52     INFO -  ++DOMWINDOW == 33 (0x11379f000) [pid = 1760] [serial = 339] [outer = 0x0]
10:51:52     INFO -  ++DOMWINDOW == 34 (0x133a0d000) [pid = 1760] [serial = 340] [outer = 0x11379f000]
10:51:52     INFO -  ++DOMWINDOW == 35 (0x112169000) [pid = 1760] [serial = 341] [outer = 0x11379f000]
10:51:52     INFO -  ++DOCSHELL 0x11f8e4700 == 15 [pid = 1760] [id = 129]
10:51:52     INFO -  ++DOMWINDOW == 36 (0x133b49000) [pid = 1760] [serial = 342] [outer = 0x0]
10:51:52     INFO -  ++DOMWINDOW == 37 (0x133b49400) [pid = 1760] [serial = 343] [outer = 0x133b49000]
10:51:52     INFO -  JavaScript warning: chrome://devtools/content/shared/vendor/d3.js, line 479: mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create
10:51:52     INFO -  ++DOCSHELL 0x11fc1cc00 == 16 [pid = 1760] [id = 130]
10:51:52     INFO -  ++DOMWINDOW == 38 (0x11d59c400) [pid = 1760] [serial = 344] [outer = 0x0]
10:51:52     INFO -  ++DOMWINDOW == 39 (0x11f9a1c00) [pid = 1760] [serial = 345] [outer = 0x11d59c400]
10:51:53     INFO -  ++DOMWINDOW == 40 (0x13541d800) [pid = 1760] [serial = 346] [outer = 0x111c92000]
10:51:53     INFO -  [1760] WARNING: Failed to retarget HTML data delivery to the parser thread.: file /builds/slave/try-m64-d-00000000000000000000/build/src/parser/html/nsHtml5StreamParser.cpp, line 966
10:51:57     INFO -  --DOCSHELL 0x11eb81f00 == 15 [pid = 1760] [id = 123]
10:51:57     INFO -  --DOCSHELL 0x1137f5b00 == 14 [pid = 1760] [id = 122]
10:51:57     INFO -  --DOCSHELL 0x1118dab00 == 13 [pid = 1760] [id = 121]
10:52:00     INFO -  --DOMWINDOW == 39 (0x111c22c00) [pid = 1760] [serial = 321] [outer = 0x0] [url = about:blank]
10:52:00     INFO -  --DOMWINDOW == 38 (0x1123bb000) [pid = 1760] [serial = 337] [outer = 0x0] [url = about:blank]
10:52:00     INFO -  --DOMWINDOW == 37 (0x133a0d000) [pid = 1760] [serial = 340] [outer = 0x0] [url = about:blank]
10:52:00     INFO -  --DOMWINDOW == 36 (0x111921800) [pid = 1760] [serial = 320] [outer = 0x0] [url = about:blank]
10:52:00     INFO -  --DOMWINDOW == 35 (0x12429a800) [pid = 1760] [serial = 328] [outer = 0x0] [url = chrome://devtools/content/webaudioeditor/webaudioeditor.xul]
10:52:00     INFO -  --DOMWINDOW == 34 (0x112083400) [pid = 1760] [serial = 322] [outer = 0x0] [url = http://example.com/browser/devtools/client/webaudioeditor/test/doc_simple-node-creation.html]
10:52:00     INFO -  --DOMWINDOW == 33 (0x113e4ac00) [pid = 1760] [serial = 330] [outer = 0x0] [url = chrome://devtools/content/shared/widgets/graphs-frame.xhtml]
10:52:00     INFO -  --DOMWINDOW == 32 (0x11370cc00) [pid = 1760] [serial = 325] [outer = 0x0] [url = chrome://devtools/content/framework/toolbox.xul]
10:52:06     INFO -  --DOMWINDOW == 31 (0x113764400) [pid = 1760] [serial = 338] [outer = 0x0] [url = http://example.com/browser/devtools/client/webaudioeditor/test/doc_media-node-creation.html]
10:52:06     INFO -  --DOMWINDOW == 30 (0x126bc4400) [pid = 1760] [serial = 333] [outer = 0x0] [url = http://example.com/browser/devtools/client/webaudioeditor/test/doc_simple-node-creation.html]
10:52:06     INFO -  --DOMWINDOW == 29 (0x11f4cac00) [pid = 1760] [serial = 332] [outer = 0x0] [url = http://example.com/browser/devtools/client/webaudioeditor/test/doc_simple-context.html]
10:52:37     INFO -  TEST-INFO | started process screencapture
10:52:37     INFO -  TEST-INFO | screencapture: exit 0
10:52:37     INFO -  404 INFO checking window state
10:52:37     INFO -  405 INFO Entering test
10:52:37     INFO -  406 INFO Initializing a web audio editor pane.
10:52:37     INFO -  407 INFO Adding tab: http://example.com/browser/devtools/client/webaudioeditor/test/doc_media-node-creation.html
10:52:37     INFO -  408 INFO Console message: [JavaScript Warning: "navigator.mozGetUserMedia has been replaced by navigator.mediaDevices.getUserMedia" {file: "http://example.com/browser/devtools/client/webaudioeditor/test/doc_media-node-creation.html" line: 21}]
10:52:37     INFO -  409 INFO Tab added and finished loading: http://example.com/browser/devtools/client/webaudioeditor/test/doc_media-node-creation.html
10:52:37     INFO -  410 INFO Console message: [JavaScript Warning: "mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create" {file: "chrome://devtools/content/shared/vendor/d3.js" line: 479}]
10:52:37     INFO -  411 INFO Waiting for event: 'navigate' on TabTarget:[object XULElement].
10:52:37     INFO -  412 INFO Console message: [JavaScript Warning: "navigator.mozGetUserMedia has been replaced by navigator.mediaDevices.getUserMedia" {file: "http://example.com/browser/devtools/client/webaudioeditor/test/doc_media-node-creation.html" line: 21}]
10:52:37     INFO -  413 INFO Got event: 'navigate' on TabTarget:[object XULElement].
10:52:37     INFO -  414 INFO TEST-UNEXPECTED-FAIL | devtools/client/webaudioeditor/test/browser_wa_properties-view-media-nodes.js | Test timed out -
10:52:37     INFO -  415 INFO finish() was called, cleaning up...
10:52:37     INFO -  --DOMWINDOW == 28 (0x113e15400) [pid = 1760] [serial = 327] [outer = 0x0] [url = chrome://devtools/content/framework/toolbox.xul]
10:52:37     INFO -  --DOMWINDOW == 27 (0x1242a1c00) [pid = 1760] [serial = 329] [outer = 0x0] [url = about:blank]
10:52:37     INFO -  --DOMWINDOW == 26 (0x11db9a800) [pid = 1760] [serial = 331] [outer = 0x0] [url = chrome://devtools/content/shared/widgets/graphs-frame.xhtml]
10:52:37     INFO -  MEMORY STAT | vsize 3337MB | residentFast 360MB | heapAllocated 117MB
10:52:37     INFO -  416 INFO TEST-OK | devtools/client/webaudioeditor/test/browser_wa_properties-view-media-nodes.js | took 45679ms
10:52:37     INFO -  Not taking screenshot here: see the one that was previously logged
10:52:37     INFO -  417 INFO TEST-UNEXPECTED-FAIL | devtools/client/webaudioeditor/test/browser_wa_properties-view-media-nodes.js | Found a tab after previous test timed out: http://example.com/browser/devtools/client/webaudioeditor/test/doc_media-node-creation.html -
10:52:37     INFO -  --DOCSHELL 0x11fc1cc00 == 12 [pid = 1760] [id = 130]
10:52:37     INFO -  --DOCSHELL 0x11f8e4700 == 11 [pid = 1760] [id = 129]
10:52:37     INFO -  --DOCSHELL 0x11f52a100 == 10 [pid = 1760] [id = 128]
10:52:37     INFO -  ++DOCSHELL 0x1121bdf00 == 11 [pid = 1760] [id = 131]
10:52:37     INFO -  ++DOMWINDOW == 27 (0x111d52000) [pid = 1760] [serial = 347] [outer = 0x0]
10:52:37     INFO -  ++DOMWINDOW == 28 (0x112083400) [pid = 1760] [serial = 348] [outer = 0x111d52000]
10:52:37     INFO -  418 INFO checking window state
(Reporter)

Comment 1

3 years ago
:jryans, can you help me find the right person to look at this?  I would prefer to fix this rather than disable it.  Ideally we will have 10.10.5 machines running by the end of the month.

Given the fact that the others tests pass, I wonder why this specific test fails.  The screenshot shows "waiting for an audio connection to be created...", this might be a simple fix.
Flags: needinfo?(jryans)
:jsantell is your best bet here.
Flags: needinfo?(jryans) → needinfo?(jsantell)
(Reporter)

Comment 3

3 years ago
thanks :jryans!
(Assignee)

Updated

3 years ago
Assignee: nobody → jsantell
Status: NEW → ASSIGNED
Flags: needinfo?(jsantell)
(Reporter)

Comment 4

3 years ago
Jordan, just checking in here to see the status, let me know if I can help at all.
Will not have time until after Fall release at the earliest to look at this, but pining Paul who might know of changes to getUserMedia or permissions for that release that could affect this
Flags: needinfo?(padenot)
(Reporter)

Comment 6

3 years ago
when is the fall release scheduled?  I want to know if we should wait or disable this on osx until then.
Nov 3rd -- I'm on 10.5,5 locally so if its reproducible, might be a quick fix
(Reporter)

Comment 8

3 years ago
oh, 1 more week until the release, maybe a few days after that for a fix.  not too bad.  If this is easy to spot/fix, that would be great- otherwise, end of next week seems reasonable.  We have 2 remaining issues as of last week- we will confirm that later this week.
(Reporter)

Comment 9

3 years ago
I suspect this failure is due to there being no devices installed, see bug 1216551 where another test was fixed related to loop on this new osx 10.10.5 platform/hardware.

I can reproduce this easily on a loaner machine, could the fix be to ignore this one test on osx?  make it fail fast with no audio hardware?
jib, is there some EnumerateDevice trickery we can do to make this not time out when there is no mic, or maybe it's not ready yet ?
Flags: needinfo?(padenot) → needinfo?(jib)
Seems a bit wallpaperish. Curious, why would 10.10.5 differ from say 10.9.5 (which I have) in whether they show as having cams/mics?

And are these tests relying on real devices on builders? Odd as AFAIK all mochitests use fake devices. [1]

But sure, you can do:

  navigator.mediaDevices.enumerateDevices()
    .then(devices => { /* use devices.length */ })
    .catch(e => console.error(e));

[1] http://mxr.mozilla.org/mozilla-central/source/dom/media/tests/mochitest/head.js?mark=11-11
Flags: needinfo?(jib)
(Reporter)

Comment 12

3 years ago
the 10.10.5 machines are new machines (r7 mac minis) as compared to the 10.10.2 (r5 mac minis).  I am not sure of the specs.
(Reporter)

Comment 13

3 years ago
just checking in to make sure this is on the schedule for this week.  I have confirmed that this is the only test left to fix for us to roll out OSX 10.10.5.  I still have a loaner machine if there is any information needed from it.
Created attachment 8684523 [details] [diff] [review]
1216542-disable-10105test.patch

Couldn't repro on my 10.10.5 machine, and hard to justify spending more than 10m on a specific OSX version failure for this seldom tool, so here's a patch to disable it
Attachment #8684523 - Flags: review?(vporof)
(Reporter)

Comment 15

3 years ago
ping on the review here!
Comment on attachment 8684523 [details] [diff] [review]
1216542-disable-10105test.patch

Review of attachment 8684523 [details] [diff] [review]:
-----------------------------------------------------------------

Just a browser.ini change, pinging you for this Joel
Attachment #8684523 - Flags: review?(vporof) → review?(jmaher)
(Reporter)

Comment 17

3 years ago
Comment on attachment 8684523 [details] [diff] [review]
1216542-disable-10105test.patch

Review of attachment 8684523 [details] [diff] [review]:
-----------------------------------------------------------------

thanks for having a bug number with this!
Attachment #8684523 - Flags: review?(jmaher) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Comment 19

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d041722de44b
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox45: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 45

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.