Closed Bug 1216738 Opened 4 years ago Closed 4 years ago

TEST-UNEXPECTED-FAIL | test_direct_update.py TestDirectUpdate.test_update, test_fallback_update.py TestFallbackUpdate.test_update | AssertionError: DownloadingPanel != CheckForUpdatesPanel

Categories

(Testing :: Firefox UI Tests, defect)

42 Branch
defect
Not set

Tracking

(firefox48 affected, firefox49 affected)

RESOLVED WORKSFORME
mozilla49
Tracking Status
firefox48 --- affected
firefox49 --- affected

People

(Reporter: whimboo, Unassigned)

References

Details

(Keywords: intermittent-failure)

Reason is that an update is already getting downloaded in the background. Most likely caused by not correctly cleaning up the system of a previous update test.

05:26:50 Traceback (most recent call last):
05:26:50   File "c:\jenkins\workspace\mozilla-aurora_update\venv\lib\site-packages\marionette\marionette_test.py", line 296, in run
05:26:50     testMethod()
05:26:50   File "c:\jenkins\workspace\mozilla-aurora_update\venv\lib\site-packages\firefox_ui_tests\update\direct\test_direct_update.py", line 26, in test_update
05:26:50     self._test_update()
05:26:50   File "c:\jenkins\workspace\mozilla-aurora_update\venv\lib\site-packages\firefox_ui_tests\update\direct\test_direct_update.py", line 20, in _test_update
05:26:50     self.download_and_apply_available_update(force_fallback=False)
05:26:50   File "c:\jenkins\workspace\mozilla-aurora_update\venv\lib\site-packages\firefox_ui_harness\testcases\update.py", line 154, in download_and_apply_available_update
05:26:50     update_available = about_window.check_for_updates()
05:26:50   File "c:\jenkins\workspace\mozilla-aurora_update\venv\lib\site-packages\firefox_puppeteer\ui\about_window\window.py", line 62, in check_for_updates
05:26:50     'Panel "Check for updates" is selected'
05:26:50 AssertionError: Panel "Check for updates" is selected
See Also: → 1216739
The message here is not that helpful. I would be good to know which pane actually is selected. Lets see if I can make it a little bit more verbose.
Depends on: 1232331
With the landing of bug 1232331 we now have a clearer failure message and it confirms my suspicion what's going on. In some cases Firefox directly starts to download the update and skips the check for updates pane. This happens most likely due a partially downloaded update file already been present. I will file or update an existing bug to get this fixed.
Summary: TEST-UNEXPECTED-FAIL | test_direct_update.py TestDirectUpdate.test_update | AssertionError: Panel "Check for updates" is selected → TEST-UNEXPECTED-FAIL | test_direct_update.py TestDirectUpdate.test_update | AssertionError: DownloadingPanel != CheckForUpdatesPanel
Depends on: 1233679
Product: Mozilla QA → Testing
Summary: TEST-UNEXPECTED-FAIL | test_direct_update.py TestDirectUpdate.test_update | AssertionError: DownloadingPanel != CheckForUpdatesPanel → TEST-UNEXPECTED-FAIL | test_direct_update.py TestDirectUpdate.test_update, test_fallback_update.py TestFallbackUpdate.test_update | AssertionError: DownloadingPanel != CheckForUpdatesPanel
Duplicate of this bug: 1216739
Fixed by my patch on bug 1233679.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
Assignee: nobody → hskupin
This is not completely fixed. We are still suffering from that issue mainly on aurora but it's with a way lower volume now. 

Checking the following log I have the suspicion that this is happening because we remove the already downloaded update while Firefox continued the update.

https://firefox-ui-tests.s3.amazonaws.com/f6d07011-d90e-4366-88af-61b998a2ae69/log_info.log

Two things which come into my mind:

1. Get rid of the initial restart but that would require work to get the mar channel settings written via Python. One other idea would be to not enable updates in the profile by default, but once we clean-up the update directory.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This failure didn't occur in the last 1.5 months. I'm going to close this bug as WFM.
Assignee: hskupin → nobody
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.