Flickering occurs after edge gesturing to landing page and then tapping show windows icon

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
10 months ago

People

(Reporter: KTucker, Unassigned)

Tracking

({polish, regression})

unspecified
ARM
Gonk (Firefox OS)
polish, regression
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe], URL)

Attachments

(1 attachment)

IF the user edge gestures from an app to the browser landing page and then taps the "Show Windows" icon, the page will flicker black.

Repro Steps:
1) Update a Aries to 20151020162500
2) Open up "Messaging" and then open up the browser.
3) Edge gesture from the messages app to the browser app and then quickly tap on the "Show Windows" icon.

Actual:
The user will notice the page flickers black during the transition. 

Expected:
No flickering occurs when tapping on the "Show Windows" icon.

Environmental Variables:
Device: Aries 2.5
Build ID: 20151020162500
Gaia: 3491a49da4d4ce45b8a682e95d0ce68892c2b8ea
Gecko: f7b746b4e91307448cb0746a41f677bfc23908b0
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 5/5 100%
See attached: video, logcat
This issue also occurs on the Flame 2.5

Flickering will occur after edge gesturing to the browser landing page and then tapping on the "Show Windows" icon.

Device: Flame 2.5 (Full Flash)(KK)(319mb)
BuildID: 20151020031318
Gaia: 3491a49da4d4ce45b8a682e95d0ce68892c2b8ea
Gecko: f7b746b4e91307448cb0746a41f677bfc23908b0
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

--------------

This issue does occur on the Flame 2.2

No black flickering occurs during the transition.

Environmental Variables:
Device: Flame 2.2
Build ID: 20151020032711
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 6b4e563acaf9
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: --- → affected
No longer depends on: 1216760
Flags: needinfo?(jmercado)
Keywords: regression
status-b2g-v2.2: --- → unaffected
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark][Systemsfe]
Created attachment 8676548 [details]
EdgeGesturingShowWindowsLogcat.txt
The steps here are somewhat of an edge case so not sure this should be nominated as a blocker.  Gregor can I get your opinion?

Let's get a window regardless.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(anygregor)
Keywords: regressionwindow-wanted
We wouldn't block the release on this issue. Its a polish bug.
Flags: needinfo?(anygregor)
Keywords: polish
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: pcheng
b2g-inbound regression window:

Last Working
Device: Flame 2.5
BuildID: 20150722005252
Gaia: b57aef5b7f52c40f88ee4c069ff722404e8e8521
Gecko: 221f20e9523e
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken
Device: Flame 2.5
BuildID: 20150722011748
Gaia: 428ca68c5711af761dcd77d1b6959361d9e8357a
Gecko: c2ce13e82986
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Last Working Gaia First Broken Gecko - no repro
Gaia: b57aef5b7f52c40f88ee4c069ff722404e8e8521
Gecko: c2ce13e82986

Last Working Gecko First Broken Gaia - repro
Gaia: 428ca68c5711af761dcd77d1b6959361d9e8357a
Gecko: 221f20e9523e

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/b57aef5b7f52c40f88ee4c069ff722404e8e8521...428ca68c5711af761dcd77d1b6959361d9e8357a

This issue appears to be caused by changes made in Bug 1185160.
Blocks: 1185160
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Etienne this issue seems to have been caused by the changes for bug 1185160.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(etienne)
Depends on: 1211877
Flags: needinfo?(etienne)

Comment 7

10 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.