Got Error in Cellular & Data panel when no SIM card is inserted

RESOLVED DUPLICATE of bug 1206471

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 1206471
3 years ago
3 years ago

People

(Reporter: gasolin@mozilla.com, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Reporter)

Description

3 years ago
When stepping into Cellular & Data with no SIM Card, got

TypeError: iccCard is null carrier.js:174:9 - 

https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/js/carrier.js#L174
(Reporter)

Updated

3 years ago
tracking-b2g: --- → backlog
(Reporter)

Comment 1

3 years ago
Yura I can't reproduce it on flame or Aries, could you provide reproducible steps?
Flags: needinfo?(yzenevich)
(Reporter)

Comment 2

3 years ago
(This issue is filed because the review comment from bug 1207471)
(In reply to Fred Lin [:gasolin] from comment #1)
> Yura I can't reproduce it on flame or Aries, could you provide reproducible
> steps?

Sure thing.

STRs (using current master):

* Open Settings app on Aries that does not have any SIM.
* Navigate to Cellular & Data section
* Observe in the console log:
  TypeError: iccCard is null at carrier.js:174:9

Looks like we assume that iccCard returned from _iccManager.getIccById(_mobileConnection.iccId) is not null which is not the case. Also note that for this case _mobileConnection.iccId is also null.
Flags: needinfo?(yzenevich)
(Reporter)

Comment 4

3 years ago
@scott is this issue already addressed in bug 1206471?
Flags: needinfo?(scwwu)

Comment 5

3 years ago
Yes this will be fixed in bug 1206471.
Flags: needinfo?(scwwu)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1206471
You need to log in before you can comment on or make changes to this bug.