Closed Bug 1216919 Opened 4 years ago Closed 4 years ago

Fix test_browser_clear_browsing_history.py

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: martijn.martijn, Assigned: martijn.martijn)

References

()

Details

Attachments

(1 file)

I'm seeing this failure happening:
TEST-START | test_browser_clear_browsing_history.py TestBrowserClearHistory.test_browser_clear_history
TEST-UNEXPECTED-ERROR | test_browser_clear_browsing_history.py TestBrowserClearHistory.test_browser_clear_history | NoSuchElementException: NoSuchElementException: Unable to locate element: button.clear-dialog-ok.danger


Traceback (most recent call last):
  File "/Users/mwargers/.virtualenvs/zapion_test2/lib/python2.7/site-packages/marionette_client-1.0.0-py2.7.egg/marionette/marionette_test.py", line 296, in run
    testMethod()
  File "/Users/mwargers/B2G/gaia_clean/tests/python/gaia-ui-tests/gaiatest/tests/functional/browser/test_browser_clear_browsing_history.py", line 41, in test_browser_clear_history
    browsing_privacy.tap_clear_browsing_history()
  File "/Users/mwargers/B2G/gaia_clean/tests/python/gaia-ui-tests/gaiatest/apps/settings/regions/browsing_privacy.py", line 32, in tap_clear_browsing_history
    self.marionette.find_element(*self._clear_button_locator)))
  File "/Users/mwargers/.virtualenvs/zapion_test2/lib/python2.7/site-packages/marionette_driver-1.0.0-py2.7.egg/marionette_driver/marionette.py", line 1713, in find_element
    return self._send_message("findElement", body, key="value")
  File "/Users/mwargers/.virtualenvs/zapion_test2/lib/python2.7/site-packages/marionette_driver-1.0.0-py2.7.egg/marionette_driver/decorators.py", line 36, in _
    return func(*args, **kwargs)
  File "/Users/mwargers/.virtualenvs/zapion_test2/lib/python2.7/site-packages/marionette_driver-1.0.0-py2.7.egg/marionette_driver/marionette.py", line 716, in _send_message
    self._handle_error(resp)
  File "/Users/mwargers/.virtualenvs/zapion_test2/lib/python2.7/site-packages/marionette_driver-1.0.0-py2.7.egg/marionette_driver/marionette.py", line 770, in _handle_error
    raise errors.lookup(error)(message, stacktrace=stacktrace)
TEST-INFO took 117704ms

SUMMARY
-------
passed: 0
failed: 1
todo: 0


This is due to bug 1214533.
While working on this, I noticed bug 1216933.
I also noticed bug 1216938.
Attachment #8676754 - Flags: review?(npark)
Attachment #8676754 - Flags: review?(jlorenzo)
Duplicate of this bug: 1216960
Comment on attachment 8676754 [details] [review]
[gaia] mwargers:1216919 > mozilla-b2g:master

r+ modulo the missing import that we have to fix. It has been found in bug 1216960. The documentation needs to be updated. If needed, you can get the diff in bug 1216960.
Attachment #8676754 - Flags: review?(jlorenzo) → review+
Scratch the part about the documentation. I hadn't reviewed bug 1216559.
Comment on attachment 8676754 [details] [review]
[gaia] mwargers:1216919 > mozilla-b2g:master

LGTM
Attachment #8676754 - Flags: review?(npark) → review+
Merged: https://github.com/mozilla-b2g/gaia/commit/cb336ee76181266721a833261b5a311e0180f3f8
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.