Closed Bug 1216933 Opened 4 years ago Closed 4 years ago

When clearing browser history, existing browser windows don't get their history cleared

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+)

VERIFIED DUPLICATE of bug 1216394
blocking-b2g 2.5+

People

(Reporter: martijn.martijn, Unassigned)

Details

(Keywords: regression, verifyme, Whiteboard: [systemsfe])

[Blocking Requested - why for this release]:

I noticed this while working on bug 1216919.
Could this be a regression from bug 1214533?

Steps to reproduce:
- Open Browser, go to some url, e.g. "http://nu.nl"
- Close Browser (by closing it from cards view)
- Open new Browser window, notice how "http://nu.nl" entry is there
- Touch home button
- Go to Settings, open Browsing Privacy
- Tap on Clear History
- In the confirmation dialog, tap on the Clear button
- Go back to the newly opened browser window
Flags: needinfo?(scwwu)
I think this regression happened before bug 1214533. The same thing could be reproduced when I checked out an earlier commit.
Flags: needinfo?(scwwu)
gmarty, another dup?
Flags: needinfo?(gmarty)
Whiteboard: [systemsfe]
If the actual result is the website still being there (when the expected result should be the history is empty), then yes, it's a dupe of Bug 1216394.

Martijn, feel free to reopen if my assumptions about actual/expected result are false.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(gmarty)
Resolution: --- → DUPLICATE
Duplicate of bug: 1216394
blocking-b2g: 2.5? → 2.5+
Keywords: verifyme
Verified it's working now in the latest build, thanks.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.