Closed Bug 1216938 Opened 4 years ago Closed 4 years ago

No history items are added to browser history after clearing history in settings

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+)

VERIFIED DUPLICATE of bug 1216394
blocking-b2g 2.5+

People

(Reporter: martijn.martijn, Unassigned)

Details

(Whiteboard: [systemsfe])

[Blocking Requested - why for this release]:

I noticed this while working on bug 1216919.
Could this be a regression from bug 1214533?

Build ID               20151020150236
Gaia Revision          11eb5d4cb2675d359d277ae17772bc75f7ccedbc
Gaia Date              2015-10-20 16:22:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f397034950304b845175f8dab8fccbdd0e8bf995
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151007.183338
Firmware Date          Wed Oct  7 18:33:51 EDT 2015
Bootloader             L1TC000118D0



Steps to reproduce:
- Go to Settings, open Browsing Privacy
- Tap on Clear History
- In the confirmation dialog, tap on the Clear button
- Open a browser window, no history should be seen and no top sites
- Go to some url, e.g. "http://nu.nl"
- Open a new Browser window

Expected result:
- In the history items, "http://nu.nl" should be shown

Actual result:
No history items shown at all
Flags: needinfo?(scwwu)
I think this regression happened before bug 1214533. The same thing could be reproduced when I checked out an earlier commit.
Flags: needinfo?(scwwu)
dup of bug 1216394?
Flags: needinfo?(gmarty)
blocking-b2g: 2.5? → 2.5+
Whiteboard: [systemsfe]
Yes totally. That's a dupe of Bug 1216394
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(gmarty)
Resolution: --- → DUPLICATE
Duplicate of bug: 1216394
Yes, works now in the latest build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.