Not receiving email from newsletters and/or mozilla@e.mozilla.org (even in spam)

RESOLVED FIXED

Status

Mozilla Foundation Communications
Email Outreach
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Akshay S Dinesh, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8676825 [details]
Screenshot of gmail search of "You're receiving this email because you subscribed to receive email newsletters and information from Mozilla."

I'm not receiving any newsletter from Mozilla. And subscribing again isn't working.

What is wrong:

* I'm subscribed to many newsletters.
* I'm not receiving any newsletter.

What did I do:

* Went to https://www.mozilla.org/en-US/newsletter/
* Put my email (asdofindia@gmail.com)
* Checked "I'm okay with Mozilla handling..."
* Clicked "sign me up"
* Saw the message "you'll now receive an email from ..."
* Went to gmail

What happened:

* There was no email from mozilla at all (even in spam)

What should have happened

* I should have received some kind of confirmation email.

Am I already subscribed to this list?

Yes. 

What does subscription preferences show?

* I clicked "modify subscription preferences" on some email I'd received in the past and reached https://www.mozilla.org/en-US/newsletter/existing/*secretcode*
* It shows "subscribe" is checked on all newsletters. Checkmark in all categories of "I'm interested in"

When was the last time I received a newsletter email from any newsletter?

* 1 mail on August 18, 2015: "Exciting news about Webmaker"
* 1 mail on 6th Feb, 2012: "Confirm interest to continue receiving email updates" (see attached screenshot)
* 16 emails between 10th Feb, 2011 and 28 Jan, 2012

When was the last time I received a confirmation email from mozilla?

* 18 July, 2014: "Thank you for subscribing to Firefox Apps & Hacks"


tl;dr - I'm not receving *any* newsletter from Mozilla despite trying hard.
(Reporter)

Comment 1

2 years ago
Created attachment 8676828 [details]
Screenshot of communication preferences page

This screenshot shows I'm subscribed to everything.

I haven't tried unsubscribing and subscribing again. It might work. But this issue might be affecting others too.
Hi Ashkay,

Thanks for flagging this. I've CC'd a couple of people who work on parts of the Mozilla email programme, and we'll investigate this further.

Have you've been subscribed to all the newsletters in the email preference centre for a while, or did you update those preferences recently?

Comment 3

2 years ago
The issue that I found here is probably related to User Experience.

The use case is described below.
A user has subscribed our newsletter a while ago.
The user forgot that, they have already subscribed and tried to subscribe it.
As soon as they entered their email ID, which in fact already added to our subscribers list, it's showing our success message (Thanks! Please check your inbox to confirm your subscription. You'll receive an email from mozilla@e.mozilla.org to confirm your subscription. If you don't see it, check your spam filter. You must confirm your subscription to receive our newsletter).

Our system is not checking whether this email ID is already added to our list or a new one.

We should tell the user that, they have already subscribed our newsletter with that particular email ID, and may be a link to update their preferences. 

Hope this will helpful.
(Reporter)

Comment 4

2 years ago
Hey Adam,
I don't remember going to email preference centre before today. I might have gone in the past, but I have no memory of going at all.

I signed up for many newsletters about 10 months back I think. You can see the confirmation mails in the first attachment.

Jafar, 
In my case, I don't know if "already subscribed" is the right description for my mail id. Because I don't get any email from those subscriptions.


I think some time somewhere my email has been blocked/dropped/magically-vanished. 

Akshay
Hello Akshay!

Thank you for alerting us to this issue! 

I took a look in our system on a deeper level and it appears that your email address had been changed to a status of "unsubscribed" on the system level (that's one level deeper than our current email preference center). If your status is "unsubscribed", when we try to send you an email (and we have given your current email subscriptions and attempts to sign up), our email system will filter out your email address before the email sends. This is why it looks like you are subscribed, but our system isn't sending to you.

The only way a subscribe can get a status of "unsubscribed" is if you had:

1) Marked an email from us as spam
2) Replied with a message that contains any of the unsubscribe terms (see below) in the email Subject line or the first 200 characters of the email body. 

I can't see past the past 90 days of history, so I'm unsure when/how/where your active status changed, but I have reactivated your subscriber. You should start to receive emails that are sent to the current newsletters you are subscribed to, and now if you sign up, you should get a welcome email right away. 

Regarding the message to confirm, once you confirm one of your Mozilla subscriptions, you are confirmed for all of your future Mozilla email newsletter signups - so it's true that we need to work on this form logic. 

Your details are very helpful and you've documented very well some user experience problems that we need to fix. I've added this information to our email platform roadmap so that we account for, and address, these issues as we work to improve our email program.

Please let me know if you questions and thank you again for filing this bug (and for working so hard to be subscribe to our emails!) I'm going to mark this bug as resolved, since I've fixed sending to your email address, and carry the work to solve for these issues in a different bug/document. Please do not hesitate to reach out if you run into further issues.

Thanks again,

Jess


---

* Unsubscribe terms
    Unsub
    Unsubscribe
    Remove
    Opt-Out
    Leave
    Common Misspellings
        unsube
        unsu
        unsubscribed
        unsubsribe
        unsubscrabe
        unscribe
        unsubscribe...
        "unsubscribe"
        unsubscribe!
        suscribir
        renove
        removed
        take me off your list
        delete me from your list
        opt out
        optout
        laeve
        leaved
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

2 years ago
Hi Jess,

Thanks for fixing that (for me at least).

I haven't consciously clicked spam in gmail for any mozilla mail. Neither does gmail show any mail for the search "to:mozilla@e.mozilla.org" or "to:mozilla@awesomeness.mozilla.org"

But, there is this email from 6 Feb, 2012 which looks like the last proper mail (excluding signups) that I received from mozilla newsletters.

Quoting:  
---------
Hi Firefox & You Subscriber,

We know how full your email inbox can get. That's why we're asking you to confirm that you'd like to continue receiving Firefox & You, our monthly newsletter with tips and tricks for getting the most out of your browser.

Forgot what's in Firefox & You? Each month we send you updates on the latest features, amazing add-ons and cool personas.

Still want Firefox & You? If you'd like to continue enjoying our monthly newsletter, please click "Yes" below. If not, simply click "No."

I would like to continue receiving the Firefox & You newsletter:

Yes   No

Thanks and happy browsing,

Your friends at Mozilla
--------

I might have clicked No to that. Back then I wasn't a Mozillian and had signed up for too many newsletters. But it's very far in the past and I can't really say.

Anyhow. Let's hope the issue affects just me. Thanks for all the help.
You need to log in before you can comment on or make changes to this bug.