Reload page command doesn't work with IETab installed due to the let/const changes from bug 589199

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: nivtwig, Unassigned, NeedInfo)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20151026])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20151021065025

Steps to reproduce:

I try to reload page on several sites using the following 3 methods :
1. Mouse click on the reload button
2. Press F5
3. Right click on the page, and click on the "reload page" icon on the popup menu that appears.

e10s is disabled. 



Actual results:

The page doesn't reload, the command is just ignored.
The only way that I found to reload the page is to click the web address field and hit "Enter"


Expected results:

The page should reload ...
It works for the latest stable build (41.0,2), but is broken on Nightly 44.0a1 (2015-10-21) and several days earlier.
I haven't been able to reproduce this. Have you tried in safe mode?
Flags: needinfo?(nivtwig)
(Reporter)

Comment 2

3 years ago
Thanks, I tried now with safe mode. It works ok with safe mode, so it is probably a problem with one of my add-ons. I will try to identify which one it is.
Flags: needinfo?(nivtwig)
That would be wonderful, thanks!
(Reporter)

Comment 4

3 years ago
The problem is with the "IE Tab" add-on .
Enabling it makes the browser ignore the "reload page" command, and disabling it makes the "reload page" command work.
Regression range: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d6059530b0317e6f6b141582b611469505256be4&tochange=cfc1820361f599c55128b29de4332f8d06511e07

This is bustage from bug 589199 and will require a (relatively simple) addon update to be fixed. See the link below for more info:
https://blog.mozilla.org/addons/2015/10/14/breaking-changes-let-const-firefox-nightly-44/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Summary: Reload page command doesn't work in Nightly 44.0a1 (2015-10-21) → Reload page command doesn't work with IETab installed due to the let/const changes from bug 589199

Comment 6

3 years ago
¡Hola Hong!

What's the preferred way to handle IE Tab issues these days?

¡Gracias!
Alex
Flags: needinfo?(pcman.tw)
Whiteboard: [bugday-20151026]
You need to log in before you can comment on or make changes to this bug.