Textbox is encoding text values

RESOLVED WONTFIX

Status

()

Core
Networking
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Tobias, Unassigned)

Tracking

41 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8677397 [details]
Screenshots of behaviour in FF41 and Opera

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20151014143721

Steps to reproduce:

Using Klocwork 10.2.1 we usually can look at the list of issues by clicking on the "XXX open" issues link


Actual results:

The search textbox content of the "issues" page is URLEncoded since Firefox 41 - no issues can be searched for anymore and being displayed.



Expected results:

The search textbox content should not be URLEncoded (worked up to Firefox 40 - always reproducable, also on other computers), so that the search works.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
That's likely caused by the change in bug 1093611.

From https://developer.mozilla.org/en-US/Firefox/Releases/41#Miscellaneous :
> The URLUtils.hash property no longer decodes URL fragment (bug 1093611).
Blocks: 1093611
Component: Untriaged → Networking
Product: Firefox → Core
The site, not Firefox, has to fix the issue.
https://www.fxsitecompat.com/en-US/docs/2015/urlutils-hash-no-longer-decodes-fragment/
So you (or IT admin in your company) need to ask Klocwork if the issue would be fixed by upgrading to the latest version of Klocwork.
(Reporter)

Comment 4

3 years ago
I see, thank you Yoshino-san - they already take action and plan to fix it in their next release.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Awesome, thanks!
You need to log in before you can comment on or make changes to this bug.