Can't load profile with space in name

VERIFIED DUPLICATE of bug 6744

Status

Core Graveyard
Profile: BackEnd
P3
normal
VERIFIED DUPLICATE of bug 6744
19 years ago
2 years ago

People

(Reporter: Phil Peterson, Assigned: selmer (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I just got back from sabbatical and tried to run the current app against a
profile I'd created before I left. The profile name is "Phil Peterson". When the
app launches, it tries to read preferences from the profile directory, but the
filename is escaped with "Phil%20Peterson" so the code which checks the
existence of the prefs.js file fails.

Not sure if this is really a prefs problem or a profiles problem.
(Assignee)

Comment 1

19 years ago
I think this problem is due to the fact that your profile was created prior to
one of our bug fixes.  The simplest fix is to wipe out the mozregistry.dat file
and try again.  If you want to preserve the contents of the profile, rename the
directory, create a new profile and point it at the new directory name.

If you can create a new profile with today's build and have this problem, then I
won't close the bug as INVALID.
(Reporter)

Comment 2

19 years ago
Sounds like a good test for profile mgr QA

Comment 3

19 years ago
I did the tests that Steve suggested:
delete mozregistry.dat
create new profile and point to old profile/directory
I was successful in reading the old prefs.js file

I think new builds will be looking for prefs.js file and Phil may have had a
prefs50.js file in his directory.
The %20 space problem is known and due for M10
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

19 years ago
*** This bug has been marked as a duplicate of 6744 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Updated

18 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 5

18 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.