Renaming a pinned site is requires too many steps and is not obvious

RESOLVED DUPLICATE of bug 1218805

Status

RESOLVED DUPLICATE of bug 1218805
3 years ago
3 years ago

People

(Reporter: tif, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

3 years ago
STR:

Prereq - Pin a site to the Homescreen (panel 1)

1. Find pinned site on your homescreen and press and hold
2. Drag icon to the toolbar to the multi-select icon (next to the trash can) which allows you to rename.

There are two usability issues with this solution:
a. this pattern is unlike anything else on the OS and it is confusing to drag an icon in order to rename it whereas normal dragging would be to re-organize.

b. the process is cumbersome forcing the user to change the name after the site has been pinned rather than allowing the change to occur during the creation flow as well.
(Reporter)

Comment 1

3 years ago
[Blocking Requested - why for this release]: Please read usability issue A. We are introducing a new interaction (which is odd and doesn't make sense) that doesn't adhere to existing OS patterns.
blocking-b2g: --- → 2.5?

Comment 2

3 years ago
cc'ing Ben about being able to select a name during the pinning process.

Comment 3

3 years ago
I'd be very interested in hearing ideas for intuitive editing - I don't think what we had before for editing was intuitive either, I've spoken to multiple people that didn't even know it was possible :/

This isn't an interaction like anything else we have on the system, but we don't really have anything else like this in the system either. I'm not sure I buy that it's all that confusing, given it's how similar things work on Android (not to say I'm a huge fan, but it's not bad for discoverability or number of steps, assuming that tap-and-hold-and-drag is a reasonable thing)
Whiteboard: [systemsfe]
Do you have a suggestion for a better interaction? Given that we only have one week before code-complete, we can't block on feedback like this unless we have a clear understanding of the risk vs. reward of the proposed fix.
Flags: needinfo?(tshakespeare)
(Reporter)

Comment 5

3 years ago
I'm just reporting! :)

Passing NI to the designer working on the feature - Liz.
Flags: needinfo?(tshakespeare) → needinfo?(ehunt)

Updated

3 years ago
Status: NEW → RESOLVED
blocking-b2g: 2.5? → ---
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1218805
Flags: needinfo?(ehunt)
You need to log in before you can comment on or make changes to this bug.