logcat errors when syncing on Android, like "JavaBinder: java.lang.RuntimeException: java.lang.Exception: PK11SDR_Decrypt returned error 0: Success"

RESOLVED DUPLICATE of bug 1153224

Status

()

Firefox for Android
Android Sync
RESOLVED DUPLICATE of bug 1153224
3 years ago
8 months ago

People

(Reporter: dholbert, Assigned: jchen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Spinning this off for remaining non-crash issues discussed in bug 1213688.

I get a bunch of error output in logcat when I sync Nightly on my Nexus 7, like the following line:
> fennec :: PasswordsRepoSession :: Got null cursor exception in PasswordsRepoSession.store

...and the following chunk:
====
0-22 13:13:40.602 19812 20234 W FxAccounts: fennec :: ServLocSynchronizerSess :: Got 7 failures storing local records! Ignoring local store failures and continuing synchronizer session.
10-22 13:13:40.914   578   617 I Timeline: Timeline: Activity_windows_visible id: ActivityRecord{1d38c83f u0 org.mozilla.fennec/org.mozilla.gecko.fxa.activities.FxAccountStatusActivity t1310} time:52570045
10-22 13:13:41.387 20209 20240 E GeckoLibLoad: Throw
10-22 13:13:41.387 20209 20240 E GeckoPasswordsProvider: Error in NSSBridge
10-22 13:13:41.388 20209 20240 E JavaBinder: *** Uncaught remote exception!  (Exceptions are not yet supported across processes.)
10-22 13:13:41.388 20209 20240 E JavaBinder: java.lang.RuntimeException: java.lang.Exception: PK11SDR_Decrypt returned error 0: Success
10-22 13:13:41.388 20209 20240 E JavaBinder: 
10-22 13:13:41.388 20209 20240 E JavaBinder:    at org.mozilla.gecko.db.PasswordsProvider.doCrypto(PasswordsProvider.java:247)
10-22 13:13:41.388 20209 20240 E JavaBinder:    at org.mozilla.gecko.db.PasswordsProvider.onPostQuery$3e5a7f14(PasswordsProvider.java:310)
10-22 13:13:41.388 20209 20240 E JavaBinder:    at org.mozilla.gecko.db.SQLiteBridgeContentProvider.query(SQLiteBridgeContentProvider.java:429)
10-22 13:13:41.388 20209 20240 E JavaBinder:    at android.content.ContentProvider.query(ContentProvider.java:1000)
10-22 13:13:41.388 20209 20240 E JavaBinder:    at android.content.ContentProvider$Transport.query(ContentProvider.java:214)
10-22 13:13:41.388 20209 20240 E JavaBinder:    at android.content.ContentProviderNative.onTransact(ContentProviderNative.java:112)
10-22 13:13:41.388 20209 20240 E JavaBinder:    at android.os.Binder.execTransact(Binder.java:446)
10-22 13:13:41.388 20209 20240 E JavaBinder: Caused by: java.lang.Exception: PK11SDR_Decrypt returned error 0: Success
10-22 13:13:41.388 20209 20240 E JavaBinder: 
10-22 13:13:41.388 20209 20240 E JavaBinder:    at org.mozilla.gecko.NSSBridge.nativeDecrypt(Native Method)
10-22 13:13:41.388 20209 20240 E JavaBinder:    at org.mozilla.gecko.NSSBridge.decrypt(NSSBridge.java:44)
10-22 13:13:41.388 20209 20240 E JavaBinder:    at org.mozilla.gecko.db.PasswordsProvider.doCrypto(PasswordsProvider.java:242)
10-22 13:13:41.388 20209 20240 E JavaBinder:    ... 6 more
====

Facts:
 - I've got latest Nightly (2015-10-22)
 - I don't have a master password configured. (I used to have one but I disabled it last week while investigating bug 1213688)
 - As of 9 days ago, the device had several entries in moz_deleted_logins that were waiting to sync (per bug 1213688 comment 12). Not sure if those are still there & might be involved with this issue.
(Reporter)

Comment 1

3 years ago
nalexander said in bug 1213688 comment 24, about my logcat output quoted above:
> So, this looks pretty terrible.  The code in question NSSBridge.cpp
> and the underlying NSS function, have changed in ages.
                                   ^(note: he meant "haven't changed")
> jchen, can you suggest a way to understand what's really happening here?
Flags: needinfo?(nchen)
(Assignee)

Comment 2

3 years ago
I looked at this the other day and the logs don't say much unfortunately, but I think we can land a diagnostic patch to get more useful logs.
Assignee: nobody → nchen
Flags: needinfo?(nchen)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1153224

Updated

8 months ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.