Closed Bug 121762 Opened 18 years ago Closed 16 years ago

bug search / query should return results in order of accuracy / most matching keywords

Categories

(Bugzilla :: Query/Bug List, enhancement, P4)

2.15
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 145588

People

(Reporter: michael.wardle, Assigned: nobody)

Details

When I perform a bug query, the results are ordered by bugzilla bug number.  It
would be far more useful if I could search for several keywords, and have
bugzilla list the bugs with the most matching keywords first, down to those with
only one matching keyword last.  Ordering within those groups would also need to
be decided (I think "Importance"/Priority would be best.)  I'm pretty sure this
is how many internet search engines (such as Altavista) function (100% relevance
-> 1% relevance).

This would make it much easier to see if there's a duplicate bug existing before
filing a new one, without needing to scroll thru hundreds of bugs.
I suppose this is doable by returning a boolean column for each word matched.
Priority: -- → P4
Target Milestone: --- → Future
Isn't this a duplicate (or could it be made a duplicate) of bug 145588?
Assignee: endico → nobody

*** This bug has been marked as a duplicate of 145588 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
clearing target for duplicate/worksforme/wontfix/invalid so they'll show up as
untriaged if they get reopened.
Target Milestone: Future → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.