the position and direction of the selection carets not correct in vertical writing mode on android.

RESOLVED DUPLICATE of bug 1217757

Status

()

Firefox for Android
Text Selection
RESOLVED DUPLICATE of bug 1217757
3 years ago
2 years ago

People

(Reporter: siqinbilige, Unassigned)

Tracking

Trunk
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8677837 [details]
android_selection_carets.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20151014143721

Steps to reproduce:

access : http://www.mongolfont.com/test/firefox/div.html on android.
and select some text.



Actual results:

the position and direction of the selection carets not correct in vertical writing mode on android.
see android_selection_carets.png



Expected results:

the position and direction of selection carets fit with vertical writing mode on android.
(Reporter)

Updated

3 years ago
OS: Unspecified → Android
Hardware: Unspecified → All
Component: Untriaged → Text Selection
Product: Firefox → Firefox for Android
Version: 41 Branch → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
In comparison, on FirefoxOS the selection carets are positioned almost OK, but they are not oriented appropriately (and along with that, they point to the bottom edge of the character rather than the left or right edge as appropriate).

I've filed bug 1217841 for the FirefoxOS issue, as I guess these are separate implementations.
Original report relates to original Android TextSelection carets.

Using the new Android/Gecko carets we get similar behavior (positioned almost OK, not oriented appropriately point to the bottom edge of the character, etc):

https://www.dropbox.com/s/yfiwcokwen0p4c6/bug1217693.png?dl=0

Tracking this, and probable solution bug: bug 1217841
(Reporter)

Comment 3

3 years ago
I want to know howto test latest firefox browser on Firefox OS.
The new version of TextSelection for mobile/Android is using the AccessibleCaret implementation, and while we handle this test case better [0], it's not perfect.

However, I think this is a better under core/selection, and looks like a DUP of Bug 1217757 - Update text selection spec for vertical writing mode.

[0] https://www.dropbox.com/s/wj9sytqyslyabje/bug_1217693.png?dl=0
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1217757
You need to log in before you can comment on or make changes to this bug.