[TV][2.5] Permission prompt up window broken on TV.

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jocheng, Assigned: rexboy)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 fixed)

Details

(Whiteboard: [ft:conndevices][partner-blocker])

User Story

As a user, I want to be prompted if Content wants to access privileged APIs on the FxOS (much like it’s done in the browser today)

Attachments

(6 attachments)

(Reporter)

Description

3 years ago
As a user, I want to be prompted if Content wants to access privileged APIs on the FxOS (much like it’s done in the browser today)
(Reporter)

Updated

3 years ago
User Story: (updated)
(Reporter)

Comment 1

3 years ago
Mark as RESOLVED since we already done this in 2.1
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

3 years ago
We need to fix the layout aspect for the warning page.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: [TV][2.5] Prompted if Marketplace Content wants to access privileged APIs on the FxOS → [TV][2.5] Layout for Prompting if Marketplace Content wants to access privileged APIs on the FxOS should be fix to fit TV aspect
(Reporter)

Comment 3

3 years ago
Created attachment 8681103 [details]
Screen Shot 2015-10-30 at 2.38.38 PM.png

Attach current layout which should be fix
(Reporter)

Comment 4

3 years ago
Hi Evelyn,
Could you help to find someone who can help fixing this? ;)
Flags: needinfo?(ehung)

Comment 5

3 years ago
Rex, could you fix this layout in TV System? Thanks.
Component: Gaia::TV → Gaia::TV::System
Flags: needinfo?(ehung)
ni? UX to make sure it is TV remote friendly
Flags: needinfo?(tchen)

Comment 7

3 years ago
dont have to do this. I prefer if we dont do this actually. the smoother the better.

Comment 8

3 years ago
Is it doable? If so, that would be an interesting feature to try out. I know Ben Francis wants to have something similar for pin-the-web

Comment 9

3 years ago
Created attachment 8682909 [details]
permission_UI.zip

This seems a UI bug to me so I will fix the broken layout first.
We can discuss new design after we fix the UI.

Hi Peko, the attached are some screenshots and the spec for phone, could you fix the layout for TV? Thanks!
Flags: needinfo?(tchen) → needinfo?(pchen)
Created attachment 8684746 [details]
website permission.zip

Hi,

Updated website permission layout.
Please take a look.
Thanks
Flags: needinfo?(pchen)
Created attachment 8684761 [details]
website permission _0.2.zip

according to Tori's request,add ok button in the second page.

Comment 12

3 years ago
Thanks Peko.

Hi Rex, are you the person who help fixing this?
Flags: needinfo?(rexboy)
taken
Flags: needinfo?(rexboy)
Assignee: nobody → rexboy

Updated

3 years ago
blocking-b2g: --- → 2.5+
Priority: -- → P2
Created attachment 8692476 [details] [review]
[gaia] rexboy7:permission-manager-merge > mozilla-b2g:master
Comment on attachment 8692476 [details] [review]
[gaia] rexboy7:permission-manager-merge > mozilla-b2g:master

Not easy to fix :-/ for CSS rules are quite different for TV and Phone.
I just make it usable on TV without considering backward-compatible.
Tested with camera/geolocation/mic dialog.

I didn't test other types of window that permission window supports. We may need to open other bugs to fix them if they're being used.
Hi Luke, may you help review this patch?
Attachment #8692476 - Flags: review?(lchang)

Updated

3 years ago
Summary: [TV][2.5] Layout for Prompting if Marketplace Content wants to access privileged APIs on the FxOS should be fix to fit TV aspect → [TV][2.5] Permission prompt up window broken on TV.
Whiteboard: [ft:conndevices] → [ft:conndevices][partner-cherry-pick]
Whiteboard: [ft:conndevices][partner-cherry-pick] → [ft:conndevices][partner-blocker]
Comment on attachment 8692476 [details] [review]
[gaia] rexboy7:permission-manager-merge > mozilla-b2g:master

Please take a look at my comments on GitHub. Thanks.
Attachment #8692476 - Flags: review?(lchang)
Comment on attachment 8692476 [details] [review]
[gaia] rexboy7:permission-manager-merge > mozilla-b2g:master

Just updated. Thanks for your suggestion.
May you review it again? Changes are in the second commit.
Attachment #8692476 - Flags: review?(lchang)
Comment on attachment 8692476 [details] [review]
[gaia] rexboy7:permission-manager-merge > mozilla-b2g:master

Looks good now. Thanks.
Attachment #8692476 - Flags: review?(lchang) → review+
Merged on master
https://github.com/mozilla-b2g/gaia/commit/4d84a7444c8e73d0e5d8800df04eb2b69174504d
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Comment on attachment 8692476 [details] [review]
[gaia] rexboy7:permission-manager-merge > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): more like a feature, the permission window hasn't been fixed ever.
[User impact] if declined: permission window can't be controlled on TV.
[Testing completed]:local test ok
[Risk to taking this patch] (and alternatives if risky): small; for it just affect permission window
[String changes made]: none
Attachment #8692476 - Flags: approval-gaia-v2.5?
(Reporter)

Comment 21

3 years ago
Comment on attachment 8692476 [details] [review]
[gaia] rexboy7:permission-manager-merge > mozilla-b2g:master

Approve for TV 2.5
Attachment #8692476 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
Hi Rex and Dan,
Could you please check the patch? Is there a way to remove the white block? Thank you.

STR:
 1. Launch Browser
 2. Go to Menu > Select "Sign in to Sync" > Press OK

Actual result
 - There is a white block at the top of the screen
 - Please see the screenshot

Expected result
 - No white block at the top of the screen

=========  Failed  ========================
Commit: 4d84a7444c8e73d0e5d8800df04eb2b69174504d [4d84a74]
Parents: ef452b89c7, ffcab689a9
Author: Rex KM Lee <rexboy@mozilla.com>
Date: 2015年11月30日 GMT+816:15:41秒

Merge pull request #33386 from rexboy7/permission-manager-merge

Bug 1217765 - [TV][System] Make permission window usable on TV.r=lchang


=========  Passed  ========================
Commit: ef452b89c76e47d27584c15996aa03da2a716531 [ef452b8]
Parents: b04e417b7b, 0d97e848e0
Author: Yi-Fan Liao <yliao@mozilla.com>
Date: 2015年11月30日 GMT+816:10:05秒

Merge pull request #33381 from begeeben/1222016_there_should_be_a_pop_up

Bug 1222016 - [TV Browser] There should be a pop-up window if user disconnect successfully, r=ferjm
Flags: needinfo?(rexboy)
Status: RESOLVED → REOPENED
QA Whiteboard: [COM=TV Browser]
Flags: needinfo?(dhuang)
Resolution: FIXED → ---
Hi Rex, the firefox account sign-in page would also use the css rule: '[role="dialog"].generic-dialog'.
So the change in tv_apps/smart-system/style/themes/default/core.css affect the style of firefox account sign-in page. 
If the change in core.css is for general purpose, I think it's better to update the 'fxa-dialog' css rule for customizing firefox account dialog to fix the issue.
Flags: needinfo?(dhuang)
(Reporter)

Updated

3 years ago
Blocks: 1214243
Let's open another bug for this.
Flags: needinfo?(rexboy)
Blocks: 1231548
No longer blocks: 1231548
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Blocks: 1231458
Blocks: 1231548
No longer blocks: 1231458
Blocks: 1237553
You need to log in before you can comment on or make changes to this bug.