Need way to bind helper apps to "protocols"

VERIFIED DUPLICATE of bug 33282

Status

()

Core
Networking
--
enhancement
VERIFIED DUPLICATE of bug 33282
16 years ago
15 years ago

People

(Reporter: Matthew Cline, Assigned: Bill Law)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I ran across a weblog where user's with an AIM account have a AIM icon with the
URL "aim:goim?screenname=Khym+Chanur&message=Hi.+Are+you+there?".  I assume that
this works with IE, and there should be some way to make it work with Mozilla,
regardless of platform.  I'm guessing that this would be tied in with helper
apps, but I'm not sure...

Comment 1

16 years ago
Have you ever tried "protozilla" (http://mozdev.org). There you can specify any
protocol type and configure very flexible how to handle them. I don't know if i
want to have this in my plain mozilla, though.
Whiteboard: DUPEME
file handling
Assignee: sgehani → law
Component: Preferences → File Handling
(Assignee)

Comment 3

16 years ago
there is a way to add Necko protocol handlers, if somebody really wants to get
this working without hacking helper apps.  Future-ing.
Target Milestone: --- → Future
QA Contact: sairuh → petersen
See bug 33282 for Linux.  On Windows and MacOS there is an OS panel to set such
bindings; if you tell your OS what app does aim: urls, we will use that app.

aim: is not handled by IE, but is handled by Netscape, internally (using the
Netscape AIM client).

*** This bug has been marked as a duplicate of 33282 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
-> networking
VERIFIED/dupe:

Basically, non-UNIX (Win+Mac) have OS level services for this. Linux does not,
hence the dupe.
Status: RESOLVED → VERIFIED
Component: File Handling → Networking
QA Contact: petersen → benc
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.