WebExtensions crash about:support

RESOLVED DUPLICATE of bug 1218364

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1218364
2 years ago
2 years ago

People

(Reporter: andym, Unassigned)

Tracking

44 Branch
All
Unspecified
Points:
---

Firefox Tracking Flags

(firefox44 affected)

Details

(crash signature)

(Reporter)

Description

2 years ago
STR:
* add in a Web Extensions add-on into about:addons, for example https://github.com/bwinton/catgif-extension
* go to about:support
* Firefox crashes

AbortMessage: [75664] ###!!! ABORT: Invalid backend: file /builds/slave/m-cen-m64-ntly-000000000000000/build/src/gfx/layers/client/ClientLayerManager.cpp, line 776
Can you look in about:crashes for a crash stack?
(Reporter)

Comment 2

2 years ago
(In reply to Bill McCloskey (:billm) from comment #1)
> Can you look in about:crashes for a crash stack?

https://crash-stats.mozilla.com/report/index/d6f358dd-f2ac-4775-91ea-5f73b2151023
It looks like this is happening here:

https://dxr.mozilla.org/mozilla-central/source/toolkit/modules/Troubleshoot.jsm#315

when the loop gets to one of our background windows.
Crash Signature: [@ mozalloc_abort | Abort | NS_DebugBreak | nsDOMWindowUtils::GetLayerManagerType]
(Reporter)

Comment 4

2 years ago
Duping to 1218364 since Luca already has a patch in the works.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1218364
You need to log in before you can comment on or make changes to this bug.