page info on mozillazine buildcomment crashes

RESOLVED WORKSFORME

Status

SeaMonkey
Page Info
P1
critical
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Mrten, Assigned: db48x)

Tracking

({crash})

Trunk
mozilla1.0
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.7+) Gecko/20020124
BuildID:    2002012403

talkback ID : TB2098196Q

I was just clicking around, i think i was on the 'media' tab when this one
happened. I saw a 'floating point' error.

there is a problem on the 'image' tab with this particular site, on which i'll
file another bug.

Reproducible: Couldn't Reproduce
Steps to Reproduce:
1. go to url
2. ctrl-i
3. click around...
Keywords: crash, stackwanted
nsImageFrame::Paint
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsImageFrame.cpp, line 1309]
PresShell::Paint
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5713]
nsView::Paint [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 272]
nsViewManager::RenderDisplayListElement
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1240]
nsViewManager::RenderViews
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1164]
nsViewManager::Refresh [d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp,
line 703]
nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1762]
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 83]
nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 854]
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 876]
nsWindow::OnPaint [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp,
line 4325]
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3247]
nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 1116]
USER32.dll + 0x1303 (0x77e71303)
USER32.dll + 0x1962 (0x77e71962)
ntdll.dll + 0x163ef (0x77f763ef) 
Keywords: stackwanted
Status: UNCONFIRMED → NEW
Ever confirmed: true
daniel?
Assignee: blaker → db48x
QA Contact: sairuh → pmac
(Assignee)

Comment 3

16 years ago
I haven't been able to reproduce, sorry.
(Assignee)

Comment 4

16 years ago
which means that if this bug is relatively easy to reproduce (as stephend seems
to have done), it's likely a regression somewhere else. I know nothing about
that code, what has changed between 2002012109 and 2002012403?

I'm upgrading now.

Updated

16 years ago
Component: XP Apps: GUI Features → Page Info

Comment 5

16 years ago
I'm having problems, too, but not crashes.  Instead, for the past month (or
more?) I've been getting inconsistent window display on the buildcomments page,
  http://www.mozillazine.org/build_comments/

It would start to display correctly, then shove all the text into a narrow band
going down the left-side.  It's like it mistakenly thinks there was a narrow
table on the page.

Comment 6

16 years ago
This same happens on www.mtv3.fi too and I can reproduce the every time on my
Linux Mozilla 0.9.9.It is definedly the "Media" tab that causes the crash.

I don't know if this is related, but I also notified that the "web site icon" of
this site has disappeared since I upgraded to 0.9.9. Same is also true for
www.cnn.com, but some other sites like www.mozilla.org and www.sourceforge.org
the "web site icon" is still visible.

Comment 7

16 years ago
WFM 2002040503/Win2K (both mtv3.fi and mozillazine.org)
Mrten: Can you reproduce this bug with a latest build?
(Reporter)

Comment 8

16 years ago
have been tinkering with 2002040303 for about 5 minutes, and no, i can't seem te
reproduce anymore. tried cnn.com and a few other sites. will try again later
tomorrow perhaps, so don't close just yet :)

a few other remarks:

the paypal image is missing, though, the first time you load the page info for
mozillazine. perhaps because it is an input?

and the, for lack of a better name, content-part of the window is continuously
vertically resizing with different images. stops doing so after manual vertical
resize of the bar in the middle.

and, same images are listed multiple times. seems like a feature.

Comment 9

16 years ago
I have not had any problems with the Mozillazine Build Comments page either, not
for several weeks.  Of course, I wasn't one who was having crashes, and I have
no idea what y'all mean by a Media tab!
(Assignee)

Comment 10

16 years ago
I haven't actually been able to personally reproduce one or two of these bugs, 
but accepting them anyway
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 11

16 years ago
I'm going to go ahead and resolve this WFM. feel free to reopen if it happens again.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.