Site Navigation Bar does not go away when moving to a file:/// URL

RESOLVED FIXED

Status

SeaMonkey
General
--
minor
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: Sebastian Leske, Assigned: Christopher Hoess (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla Build: 0.9.7
User Agent: Mozilla/5.0 (X11; U; Linux i686; ; rv:0.9.7) Gecko/20011230
If you set the Site Navigation Bar (SNB) to only show as needed, via menu
View - Show/Hide - Site Navigation Bar - Show Only As Needed
it should only display the SNB on pages which use it.
However, when the SNB is displayed, entering a file:/// URL
does not make it go away, even though is is not used.

To reproduce:
-------------
Set SNB to show only as needed via menu:
View - Show/Hide - Site Navigation Bar - Show Only As Needed
Go to a site that uses LINK elements, such as 
http://slashdot.org . The SNB appears -- so far, so good.
Now enter a file URL in the location field: 
file:///
A directory listing is displayed, but the SNB does not go away,
as it should.

Remarks:
--------
Opening the file:/// URL in a fresh window
does not make the SNB appear. 

Similarly, going to a http: URL which does not use the SNB does
make it disappear, and it does not reappear when going to a file:///
URL afterwards.
(Assignee)

Updated

17 years ago
Blocks: 103053

Comment 1

17 years ago
WFM on Linux build 2002012508 and Windows build 2002012403.

Comment 2

17 years ago
Sebastian, please try this again in 0.9.8 when it is released, or with any
recent nightly. I believe I fixed this with bug 103097. Let us know in this bug
what the results with 0.9.8 are.

I'm almost tempted to mark this WFM or a dup of 103097 based on the WFM report
already in this bug, but it would be nice to get confirmation from the original
reporter that it works for him too first :)
(Assignee)

Comment 3

17 years ago
WFM on fresh Linux CVS.  Reassigning to self until we're sure it's resolved.
Assignee: asa → choess

Comment 4

17 years ago
WFM on Win98 Build ID: 2002013103
(Reporter)

Comment 5

17 years ago
(Original submitter) With 0.9.8 / Linux, now WFM also. Guess it's
been fixed, closing as FIXED. 
Thanks for the good work!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.