Links missing in Site Navigation Toolbar if LINK el. contains hreflang

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Sebastian Leske, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
If a page uses a <LINK> element with a hreflang attribute, this
seems to cause the Site Navigation Bar not to display links for subsequent
<LINK> elements sometimes.
Also, in these cases the Site Navigation Bar is not displayed at all if it is
set to "Show as Needed", even though, when switched on, it does
show some links (though not all). (See Remark below).

The URL given above is an example of this: Mozilla only displays a
"Previous" link in the Site Navigation Bar for it, even though it
has more links (view the source to check).

To reproduce:
-------------
Attached are two HTML files, bug.html and works.html , which demonstrate
this. The files are identical except for one line. Excerpt:
bug.html:
<link rel="prev" href="file_2.htm" hreflang="en-gb">
<link rel="next" href="file_3.htm">
works.html:
<link rel="prev" href="file_2.htm">
<link rel="next" href="file_3.htm">

However, when bug.html is loaded, only the "Previous" link is displayed in
the Site Navigation Bar. works.html displays both links, as it should.

Remarks:
--------

If you switch the Site Navigation Bar on manually via the View menu after
loading the page, all links are displayed, but only until you hit "Reload".
Wierd...
(Reporter)

Comment 1

16 years ago
Created attachment 66444 [details]
This demonstrates the bug; you may need to reload the page once to see it.
(Reporter)

Comment 2

16 years ago
Created attachment 66445 [details]
Almost the same as bug.html, but this time the bug does not occur.
Well on linux 2002012421, I am always able to view the links in the site
navigation bar.  However on the testcase with the hreflang="" attribute, the
tooltip shows as ":" (just a colon).  Otherwise, I am still able to click and
use the links as normal.

So this WFM as the problem is described.

Comment 4

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020126
testcase and URL both work for me.

Reporter: what version are you using?
(Reporter)

Comment 5

16 years ago
(I'm the submitter.) The bug occurs with Mozilla 0.9.7 , 
User Agent String: Mozilla/5.0 (X11; U; Linux i686; ; rv:0.9.7) Gecko/20011230

I downloaded the binary from mozilla.org :
http://ftp.mozilla.org/pub/mozilla/releases/mozilla0.9.7/mozilla-i686-pc-linux-gnu-0.9.7-MathML-SVG-XMLterm.tar.gz

I'll try again with Mozilla 0.9.8 when that comes out.
(Assignee)

Comment 6

16 years ago
wfm. please reopen if you're still seeing with 0.9.8 or newer
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

16 years ago
With 0.9.8 / Linux, it now WFM. Seems to be fixed.
Good work!
BTW, the tooltip for the Previous link still only shows as a ":", 
as reported by #4.
Should I open a new bug for this?
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.