Cannot install add-ons into the Simulator

RESOLVED WORKSFORME

Status

Firefox OS
Simulator
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: mikehenrty, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

STR:

Open webIDE
Install 3.0 simluator
Run 3.0 simulator using webIDE
Try to install add-on

Expected result:
Add-on is installed

Actual result:
Get error saying:
"Operation failed: installing and running app (installationFailed): [NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) nslZipReader.getInputStream
loader.js -> server/actors/webapps.js :: run :: line 35"

^^ paraphrased since I'm not able to copy these errors from webIDE.
I imagine that's because Simulator 3.0 is too old to support addons.
Could you test this one?
  https://queue.taskcluster.net/v1/task/XQ3VvYJeT4ap_foyn2nodw/runs/0/artifacts/public/build/fxos-simulator-2.5.20151025080657-linux64.xpi
If that's the case, it relates to bug 1198877.
(In reply to Alexandre Poirot [:ochameau] from comment #1)
> I imagine that's because Simulator 3.0 is too old to support addons.
> Could you test this one?
>  
> https://queue.taskcluster.net/v1/task/XQ3VvYJeT4ap_foyn2nodw/runs/0/
> artifacts/public/build/fxos-simulator-2.5.20151025080657-linux64.xpi

Thanks for the quick reply Alex. Seems likely. Do you know where I can find the Mac version of this?
Flags: needinfo?(poirot.alex)
Here is the lastest:
http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2015-10-06-03-02-03-mozilla-central/fxos-simulator-2.5-mac64.xpi

But note that it is an old build, it should work for addons as addons are older than early october.
We no longer have simulator nightlies since b2g desktop has been shutdown.
Flags: needinfo?(poirot.alex)
Thank you, it's working :)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.