Closed Bug 12183 Opened 21 years ago Closed 21 years ago

parser fails to create empty document

Categories

(Core :: DOM: HTML Parser, defect, P3)

defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: brendan, Assigned: vidur)

References

()

Details

Warren set me straight on this: an nsIStreamListener, which the parser
implements, must handle the case where OnStartRequest and OnStopRequest are
called with no intervening OnDataAvailable calls.  That's a legit sequence
corresponding to an empty document.  It's easiest to reproduce in the M9 branch
using the test URL above (branch changes should land on trunk soon).

/be
*** Bug 12259 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Ok-- but that's news to me. Perhaps Warren should have made that clear to all of
us. I'll add this test to my test library.
Me make it clear? I just found out myself! :-)
Ok -- I'll update the parser code to make sure we act reasonably in this case.
Assignee: rickg → vidur
Status: ASSIGNED → NEW
The parser doesn't create a blank document because it never gets called.
Vidur, do you know where this gets hooked up at the doc loader level?
I'd like to beat the christmas rush and see if one of you would like to include
a testcase (or steps to recreate,) or else mark this as a developer regression.

Thanks awfully much.
Moving all non-DOM[012], non-crash bugs to M15.
Depends on: 14049
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Works with latest build. Tested by typing javascript:'' into the URL bar and
then dumping the content model which showed:

webshell=015D20C0
html@01E36E3C refcount=3<
  head@01E36DBC refcount=2<
  >
  body@01E9B11C refcount=3<
  >
>
Status: RESOLVED → VERIFIED
trusting developer...
You need to log in before you can comment on or make changes to this bug.