Closed Bug 1218318 Opened 4 years ago Closed 4 years ago

Home screen looks awkward when dragging to the right and tapping with second finger

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1219391

People

(Reporter: twen, Unassigned)

Details

Attachments

(1 file)

Attached image screenshot
Home screen becomes a split of apps and pin the web screen. Although user can drag it back to focus on apps or pin the web screen, a split screen is awkward. 

[Repro Steps]:
1. Swipe to left for pin the web screen
2. When in halfway, tap the screen with second finger

[Actual Result]: 
The screen stays as it is. 

[Expected Result]:
Screen scrolls to the left to apps page or scrolls to the right to pin the web page. 
Not in the middle. 

[Build Info]:
Build ID               20151025085903
Gaia Revision          1c6628ed1e40575e5ec3669ab6ef389d4ebeea65
Gaia Date              2015-10-23 17:01:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d53a52b39a95dced722cca90ac74529b66dd5253
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151025.081846
Firmware Date          Sun Oct 25 08:18:54 UTC 2015
Bootloader             s1

Open this bug under gaia homescreen component, let me know if you think otherwise :)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1190469
I can still reproduce this issue with bug 1190469 fixed. Please take another look. Thanks.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
You're probably hitting bug 1219391 now. This bug isn't particularly useful as there's nothing home screen can do about this - these are Core bugs with the APZ (so Panning and Zooming). It would be useful to file any new bugs you find under that component with easy-to-follow STR so that gfx can deal with them. If you find more, cc me and I'll make sure they don't get lost.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1219391
You need to log in before you can comment on or make changes to this bug.