Closed Bug 1218356 Opened 5 years ago Closed 2 months ago

Add WebRTC stats to data channel

Categories

(Core :: WebRTC, defect, P3)

44 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed
Blocking Flags:

People

(Reporter: shacharz, Assigned: ng)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(5 files)

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.27 Safari/537.36

Steps to reproduce:

create a datachannel 
browse to about:webrtc / call pc.getStats()



Actual results:

only sdp information is showed


Expected results:

Should show/return
number of bytes received
number of bytes sent
connection RTT
etc'..
Blocks: 964161
Component: Untriaged → WebRTC
Product: Firefox → Core
Maire - this may be a good bug to put one of the new people on, or as a 2nd or 3rd (etc) bug.
Flags: needinfo?(mreavy)
Yep, I briefly mentioned this one on irc to Nico, who just started yesterday.  This is a little too involved for a "first bug", but it would be a good bug to target fixing for this quarter.
Rank: 25
Flags: needinfo?(mreavy)
Priority: -- → P2
backlog: --- → webrtc/webaudio+
RTCStatsReport.webidl appears to reflect WD20141021 and not the latest version of the document, WD20150206.
The peerconnnection RTCStatsType, and the fractionLost entry in RTCInboundRTPStreamStats are both missing from RTCStatsReport.webidl, and WD20141021. Both are present in WD20150206. Additionally, there are two more small changes outlined in section 7.1 of WD20150206 that may need to be addressed.
We might want to open a separate bug for that since since bug is specific to stats for data channels.
Depends on: 1233849
Any update on this?
Mass change P2->P3 to align with new Mozilla triage process.
Priority: P2 → P3

Spec: https://w3c.github.io/webrtc-stats/#dom-rtcdatachannelstats

Note: We do not yet support transport stats, and transportId acts
as key back into the collection of all stats, so for now transportId
must not appear in this object (it has no object to point to).
See bug 1225723

Depends on D57104

Assignee: nobody → na-g
Status: NEW → ASSIGNED

Note that transportId is not implemented and is not a stat but a key back into
the stats report. It identifies the related transport stats object. We don't
have transport stats, so this can not be implemented at the moment.

Depends on D57115

Hi,
I noticed that round trip time is not part of the patch, can it be included?
references for help:
https://github.com/w3c/webrtc-stats/pull/503
https://tools.ietf.org/html/rfc6458#section-8.2.2 spinfo_srtt

Shachar, this patch only covers the RTCDataChannelStats dictionary. The smoothed round trip time will likely make it in when we add support for RTCSctpTransportStats.

Attachment #9121608 - Attachment description: Bug 1218356 - P4 - Update DataChannel stats WPT INI;r?mjf → Bug 1218356 - P3 - Update DataChannel stats WPT INI;r?mjf
Attachment #9121607 - Attachment description: Bug 1218356 - P3 - Adding DataChannel mochitestst;r?mjf → Bug 1218356 - P4 - Adding DataChannel mochitestst;r?mjf
Attachment #9121607 - Attachment is obsolete: true
Attachment #9121608 - Attachment description: Bug 1218356 - P3 - Update DataChannel stats WPT INI;r?mjf → Bug 1218356 - P3 - Update DataChannel stats WPT INI, prevent early collection DataChannels in WPT;r?mjf,r=jib!
Attachment #9121608 - Attachment description: Bug 1218356 - P3 - Update DataChannel stats WPT INI, prevent early collection DataChannels in WPT;r?mjf,r=jib! → Bug 1218356 - P3 - Update DataChannel stats WPT INI, prevent early collection DataChannels in WPT;r?mjf r?jib
Attachment #9121608 - Attachment description: Bug 1218356 - P3 - Update DataChannel stats WPT INI, prevent early collection DataChannels in WPT;r?mjf r?jib → Bug 1218356 - P3 - Update DataChannel stats WPT INI, prevent early collection DataChannels in WPT;r?mjf,jib
Attachment #9121607 - Attachment is obsolete: false
Pushed by na-g@nostrum.com:
https://hg.mozilla.org/integration/autoland/rev/c270d9e461cb
P0 - Add WebIDL for RTCDataChannelStats;r=smaug
https://hg.mozilla.org/integration/autoland/rev/9d7f77f76afa
P1 - Add serializers for RTCDataChannel stats;r=dminor
https://hg.mozilla.org/integration/autoland/rev/0a36097a6a94
P2 - Implement the RTCDataChannel stats;r=dminor
https://hg.mozilla.org/integration/autoland/rev/e5a622ee082d
P4 - Adding DataChannel mochitestst;r=mjf
https://hg.mozilla.org/integration/autoland/rev/7ac31dadbb7d
P3 - Update DataChannel stats WPT INI, prevent early collection DataChannels in WPT;r=mjf,jib
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/23871 for changes under testing/web-platform/tests
Upstream PR merged by moz-wptsync-bot
Regressions: 1642266
Duplicate of this bug: 1621429
You need to log in before you can comment on or make changes to this bug.