reply to thread for rejected add-on isn't showing in review/submission tools

RESOLVED FIXED

Status

Marketplace
Developer Pages
P2
major
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: eviljeff, Assigned: ngoke)

Tracking

Avenir
Points:
---

Details

(URL)

(Reporter)

Description

2 years ago
This note:
    "Weird, may I know the testing environment? (device, build identifier...)
is developer mode on?"

Was a reply to my rejection of version 1.0 of system-sound-switch but the reply doesn't show in the review [2] or developer tools [1].

[1] https://marketplace.firefox.com/content/addon/dashboard/system-sound-switch
[2] https://marketplace.firefox.com/content/addon/review/system-sound-switch
(Assignee)

Comment 1

2 years ago
I'll check it out ASAP, reply through the tools in the meantime.
(Reporter)

Comment 2

2 years ago
(In reply to Kevin Ngo [:ngoke] from comment #1)
> I'll check it out ASAP, reply through the tools in the meantime.

my reply to his (unseen) reply didn't work cia the tools either.  Might be something to do with it being a rejected version or the add-on not having a current/latest version.
(Assignee)

Comment 3

2 years ago
What happens when you try to put a note in the tools (e.g., response status code of the POST)?

Updated

2 years ago
Assignee: nobody → kngo
Priority: -- → P2
(Reporter)

Comment 4

2 years ago
(In reply to Kevin Ngo [:ngoke] from comment #3)
> What happens when you try to put a note in the tools (e.g., response status
> code of the POST)?

looks like its working now - not sure what else fixed it.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

2 years ago
Re-opening this - the original problem, of developer replies not appearing - is still happening.  Trying to get further clarification of the origins (email or website) from the developer.

Can provide some sample thread IDs if that helps?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

2 years ago
Blocks: 1217466
No longer blocks: 1195470
Severity: normal → major
(Assignee)

Comment 6

2 years ago
Looking into this.
(Assignee)

Comment 7

2 years ago
I fixed so that reviewer replies are visible. Before they were being set as internal.

Investigating developer replies.
(Reporter)

Comment 8

2 years ago
I've just experienced this with an app too - 
https://marketplace.firefox.com/comm/thread/35130 is missing a reply "Do you have a "Music" folder on your sd?"
(Assignee)

Comment 9

2 years ago
ok, waiting on db creds to find out exactly what's up
(Assignee)

Comment 10

2 years ago
Found the issue, it was a regression: https://github.com/mozilla/zamboni/pull/3432
(Assignee)

Comment 11

2 years ago
The notes are created, just not showing up in the endpoints.
(Assignee)

Comment 12

2 years ago
https://github.com/mozilla/zamboni/pull/3432
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

2 years ago
STR:

On content tools, have a reviewer account and a non-reviewer developer account.

1. Ensure that reviewers can see developer comments.
2. Ensure that developers can see reviewer comments.
You need to log in before you can comment on or make changes to this bug.