Closed Bug 121839 Opened 18 years ago Closed 15 years ago

image with backslash in URL not displayed

Categories

(Tech Evangelism Graveyard :: Dutch, defect)

x86
Windows NT
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 64488

People

(Reporter: gaele, Assigned: tristan)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122106

The page
  http://www.student.utwente.nl/~hardboard/evenementenfotos.html
contains IMG tags with wrong URLs in it. The URLs contain backslashes.
Example
  <img src="pictures\bordzager.jpg">

If I go directly to the image
  http://www.student.utwente.nl/~hardboard/pictures\bordzager.jpg
then the URL is replaced by 
  http://www.student.utwente.nl/~hardboard/pictures/bordzager.jpg
and the image is displayed.

The original page
  http://www.student.utwente.nl/~hardboard/evenementenfotos.html
however does not display the image. It doesn't even display a broken image icon.



Reproducible: Always
Steps to Reproduce:
1. visit the page
2.
3.

Actual Results:  same result

Expected Results:  show the image

Part of the page:

<html>
<body background="bloem2.jpg" text="yellow" link="yellow" vlink="orange">

<img src="pictures\bordzager.jpg"> <br>
De finale van de bikkelcontest 2001: Boardzagen <br>
<img src="pictures\tafelsurfen.jpg"> <br>
Tafelsurfen op de valentijnsnieuwjaarborrel 2001 <br>
<br>
<img src="pictures\HIDDO1.JPG"> <br>
Oudhollands boardwerpen: Hiddo<br>
<img src="pictures\JASPER1.JPG"> <br>
Jasper heeft al moeit het board op te tillen. <br>
AFAIK a "\" is invalid.

Hi
.. ~hardboard/pictures\bordzager.jpg
that would mean:

FILE pictures\bordzager.jpg in the directory ~hardboard...

I know: MS IE would display the picture, because IE thinks \ and / are the same..

but mozilla does imho the right thing...
resolving WONTFIX .. maybe someone recalls the bug that this can be dup'd against?
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → WONTFIX
reopening.  This is evangelism.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
see details in bug 32895.
Assignee: darin → nitot
Status: UNCONFIRMED → NEW
Component: Networking: HTTP → Europe: West
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: tever → caillon
Version: other → unspecified
According to bug 32895 this seems to have been fixed. I.e. the \ will only be
escaped. The test URL
  http://www.undergrad.math.uwaterloo.ca/~dj3vande/rfc\compliance.html
confirms this. 

However my Mozilla still (or again?) changes \ to /. On NT as well as on Win95.

What I would expect is an error message if I request the wrong URL directly, and
a page with broken image icons if they appear in a page.
 
The current behaviour is inconsistent.

When does this happen? We still do it if you just put something like
c:\path\file into the urlbar. Then it gets changed to file:///c|/path/file. 
Well, it happens with 'http://' as well.
Well, that's bad, must be somewhere in the docshell ... I will investigate ...
The fixup happens inside nsDefaultURIFixup.cpp for http, https and ftp. I was
under the impression this stuff has been dropped a long time ago. On windows we
replace every \ with / when a http, https or ftp url is typed into the urlbar.
This happens on the whole url, not only the directory-part, which is really,
really wrong. 

In my opinion this fixup should only happen on windows when someone types
something in the urlbar that looks like a filepath. Other then that this fixup
should not happen at all.

But that is outside the scope of this bug, which is really about a link
containing  a \ where it should be a /.
filed bug 122270 as a spinoff ...
The QA Contact for Europe: West has changed to
brantgurganus2001@cherokeescouting.org.  If there is a reason for you to stay as
the QA Contact, feel free to change back.
QA Contact: caillon → brantgurganus2001
404.
Status: NEW → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → INVALID
v
Status: RESOLVED → VERIFIED
tech evang june 2003 reorg
Component: Europe: West → Dutch
*** Bug 250449 has been marked as a duplicate of this bug. ***
*** Bug 258167 has been marked as a duplicate of this bug. ***
*** Bug 271938 has been marked as a duplicate of this bug. ***
*** Bug 283204 has been marked as a duplicate of this bug. ***
Status: VERIFIED → REOPENED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 64488 ***
Status: REOPENED → RESOLVED
Closed: 18 years ago15 years ago
Resolution: --- → DUPLICATE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.