Closed Bug 1218421 Opened 6 years ago Closed 6 years ago

[10.11] Context Menu & Address Bar Fonts are Serif

Categories

(Core :: Graphics: Text, defect)

41 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1201318

People

(Reporter: blaguskida15, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: fonts, Whiteboard: [gfx-noted])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20151014143721

Steps to reproduce:

This issue seems to have started after I updated to OS X El Capitan.


Actual results:

The fonts in the context menus and address bar have been changed to a sans-serif font. It's very distracting. 


Expected results:

I'm not sure what the default font for Firefox's context menu and address bar are supposed to be, but I know they're supposed to be san-serif. (perhaps Helvetica or Arial?)
Can you reproduce the issue when you start Firefox in a brand new profile?
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles

If the problem persists in the brand new profile, can you also reproduce it in the latest Nightly with that same profile?
https://nightly.mozilla.org

Possibly related: bug 1201318.
Blocks: el-capitan
Component: Untriaged → Graphics: Text
Flags: needinfo?(blaguskida15)
Keywords: fonts
OS: Unspecified → Mac OS X
Product: Firefox → Core
Hardware: Unspecified → x86
Summary: Context Menu & Address Bar Fonts are San-Serif → [10.11] Context Menu & Address Bar Fonts are Serif
The issue was still there in a new profile. The issue was resolved in Nightly. Any idea how to fix it in Firefox?
Flags: needinfo?(blaguskida15)
If the problem is fixed in nightly then we can figure out what patch fixed it in nightly then we can possibly uplift it to aurora and beta. However it would still take some time before it made it to Firefox release.

You can use http://mozilla.github.io/mozregression/ to figure out what fixed the problem.
Jonathan, do you happen know any bugs that are likely to have fixed this that landed recently?
Flags: needinfo?(jfkthame)
Sounds like bug 1201318 or one of its related issues; jdaggett and mstange have been working on those issues, iirc. I'm not sure of the exact state of the patches, or whether anything could be uplifted.... passing needinfo? to John & Markus.
Flags: needinfo?(mstange)
Flags: needinfo?(jfkthame)
Flags: needinfo?(jdaggett)
I'll let John answer the uplift question. Bug 1201318 fixed the font face, but the letter spacing (bug 1213280) still needs to be fixed.
Flags: needinfo?(mstange)
Status: UNCONFIRMED → NEW
Depends on: 1201318, 1213280
Ever confirmed: true
Whiteboard: [gfx-noted]
I've posted screenshots of Nightly on bug 1201318 which I believe should resolve the problem here. Requested uplift to aurora/beta so that this fix will be included with FF42.
Flags: needinfo?(jdaggett)
Reporter, if possible could you confirm that Firefox Nightly build displays correctly on your machine?

https://nightly.mozilla.org/
Flags: needinfo?(blaguskida15)
(In reply to John Daggett (:jtd) from comment #7)
> I've posted screenshots of Nightly on bug 1201318 which I believe should
> resolve the problem here. Requested uplift to aurora/beta so that this fix
> will be included with FF42.

FF42 has already merged to mozilla-release, so it's too late for that unless it gets uplifted to the *release* (not just beta) channel.
(In reply to John Daggett (:jtd) from comment #8)
> Reporter, if possible could you confirm that Firefox Nightly build displays
> correctly on your machine?
> 
> https://nightly.mozilla.org/


Nightly does fix the issue.
Flags: needinfo?(blaguskida15)
Great! Marking this as a duplicate of bug 1201318.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1201318
The address bar & context menu font is getting harder to read than it was before.

I'm using Firefox 42.0 on OS X El Capitan 10.11.1
(In reply to blaguskida15 from comment #12)
> Created attachment 8683716 [details]
> Screen Shot 2015-11-05 at 9.52.56 AM.png
> 
> The address bar & context menu font is getting harder to read than it was
> before.
> 
> I'm using Firefox 42.0 on OS X El Capitan 10.11.1

See comment 11. This issue has only been fixed in Firefox 44+ and is tracked in bug 1201318.
You need to log in before you can comment on or make changes to this bug.