Please deploy loop-client 0.21.0 to STAGE

VERIFIED FIXED

Status

Cloud Services
Operations: Deployment Requests
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: standard8, Assigned: bobm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
------------------
RELEASE NOTES
------------------
https://github.com/mozilla/loop-client/releases

COMPARISONS
https://github.com/mozilla/loop-client/compare/0.20.0...0.20.1
https://github.com/mozilla/loop-client/compare/0.20.1...0.20.2
https://github.com/mozilla/loop-client/compare/0.20.2...0.21.0

TAGS
https://github.com/mozilla/loop-client/releases/tag/0.21.0
https://github.com/mozilla/loop-client/commit/145e1cd85381e622f6e9dafcfb82109b431baf05

CHANGELOG
0.21.0 (2015-10-26)
-------------------

- Bug 1170757 - Enabled eslint dot-location + no-empty rules for Hello
- Bug 1182079 - Fix intermittent test failure loading the Loop's ui-showcase on debug builds by extending the page load timeout, and improve the failure naming.
- Bug 1192738 - Drop the old aspect ratio calculation code now that Loop's media layout refactors have been completed.
- Bug 1193311 - Enable eslint rules for Loop: eqeqeq (for content code).
- Bug 1178393 - Countdown to zero warnings in standalone test suite.
- Bug 1194738 - Drop some obsolete pref handling from Loop, and some old room conversation styles.
- No Bug - correct comment to say 'browser', not 'tab'.
- Bug 1190442 - Visual refresh for Loop FTU panel.
- Bug 1184559 - Implement the refreshed design for the conversation toolbar.
- Bug 1189287 - Update the tooltip strings for the mute and unmute video buttons inside the Hello conversation toolbar.
- Bug 1197795 - Update Loop's library versions (eslint 1.2.1, sinon 1.16.1).
- Bug 1184917 - Implement the refreshed design for 'Edit' conversation toolbar button.
- Bug 1126733 - Brief message appears when entering a standalone room that the user is the only person in the room.
- No bug - Remove obsolete jshint files from Loop's standalone as Loop now uses eslint
- Bug 1198841 - Brief message to invite someone to join when joining a room with someone already there
- Bug 1194622 - Provide indication of loading when waiting for the room list
- Bug 1201446 - Don't expose websocket reasons to the view code where we have a specific failure detail available.
- Bug 1198891 - Tab/Window Sharing icon should turn blue when sharing is active.
- Bug 1202402 - Nothing shown on the standalone UI when a peer exits the room
- Bug 1184933 - Part 1. Implement the refreshed design for the failure view.
- Bug 1184933 - Part 2. Add the settings menu onto the failure view.
- Bug 1203529 - Bad display when starting an audio-only call to a contact.
- Bug 1196499 - Update Loop empty state for no conversations.
- Bug 1203850 - Rename Loop's srcVideoObject and related variables/attributes to clarify they are about the media element, not just the video.
- Bug 1204577 - remove invalid CSS properties from Loop/ Hello source files.
- Bug 1200689 - Style Hello 'Share' menu consistently with gear icon menu.
- Bug 1199120 - Overlapping buttons in conversation window
- Bug 1184940 - Implement the refreshed design for the edit context view.
- Bug 1184940 - Implement the refreshed design for the edit context view
- Bug 1205658 - Hello Spinner Blue should match other blue elements in Hello
- Bug 1199213 - Part 2. Remove the old css relating to standalone call-url handling from Loop.
- Bug 1199213 - Part 3. More cleanup of conversation related css after call-url code removal.
- Bug 1188771 - Inform users when they can't use the Hello service due to ToS compliance.
- Bug 1208201 - Simplify setup flows for standalone and desktop in Loop's activeRoomStore.
- Bug 1208515 - The feedback view has the incorrect blue for the Hello icon and button.
- Bug 1208466 - Part 1. Create a new ToS view for Loop's standalone, ready for integration into the handled-in-Firefox views.
- Bug 1208466 - Part 2. If an owner of a Loop link clicks their own link and join, make it open the conversation window.
- Bug 1208466 - Part 3. Fix display when opening room, and make the opened room text non-bold.
- Bug 1171962 - introduce telemetry histogram that counts the amount of sessions that exchanged one or more chat messages.
- Bug 1209078 - Part 2. If a user attempts to open their own room within Firefox when the room is already open, provide a message to inform the user.
- Bug 1204101 - Fix for Loop settings menu positioning where menu gets cropped from longer text.
- Bug 1205206 - Move Loop Standalone Terms of Service text from footer to under Join button.
- Bug 1155923 - Removing moz prefix from RTC interfaces.
- Bug 1209029 - .settings-menu .icon classes in Loop's panel are obsolete and should be removed.
- Bug 1193674 - If room context/name is unavailable, the title of the standalone is displayed as "{{roomName}} - Firefox Hello".
- No bug. Fix Loop's eslint configuration, due to fallout from bug 1203520.
- Bug 1184924 - Implement the refreshed design for the invitation overlay
- Bug 1184921 - allow custom buttons to be added to the chatbox titlebar and implement one for Hello that closes the window when clicked.
- Bug 1210331 - Clean up strings for conversations panel and conversation invite
- Bug 1204343 - Loop's accept call buttons has different heights and looks strange.
- Bug 1209592 - Fix Loop's screenshare dropdown being misplaced on large window sizes.
- Bug 1210513 - Loop's direct calls don't cancel properly if you click the hangup button on the toolbar.
- Bug 1204345 - Last letter at bottom right can be cut off.
- Bug 1172662 - ICE failures occuring in Loop conversations should be reported to the user.
- Bug 1208047 - Close the dropdown menu for sharing on Loop's conversation window as soon as an item is clicked, rather than leaving it open in a potentially confusing state.
- Bug 1211592 - The Copy Link and Email Link buttons show cursor:default, but the other buttons (Camera,Mic,Share Screen,Settings) show cursor:pointer
- Bug 1211563 - Invite buttons should be underneath "Invite a friend" text in popped-out view
- Bug 1212272 - 'make dist' for the Loop standalone doesn't update the css and supplementary files properly.
- Bug 1209632 - Removing footer from Loop Standalone, moved Logo to mediaLayoutView.
- Bug 1200693 - Modify aspect ratio so that top and bottom black bars are not seen when waiting alone in the conversation window.
- Follow-up to bug 1212272 - use the correct cp command.
- Bug 1212787 - Revert Loop's conversation toolbar button sizes due to bug 1209632 causing a visual regression.
- Bug 1212083 - Part 1. Remove the direct calls UI from Loop.
- Bug 1212083 - Part 2. Remove the unused files previously associated with direct calls.
- Bug 1201308 - Leave / Exit conversation button always present.
- Bug 1209589 - Collect Google Analytics data for users on IE 10 & 11.
- Bug 1209686 - Remove Standalone header from Loop.
- Bug 1217335 - Room context is no longer shown when loading the Loop standalone UI.
- Bug 1217369 - "Welcome to ..." has extra padding on Loop's standalone UI making it feel strange.
- Bug 1213848 - Change the Loop panel display when a user enters their own room to stop them entering other rooms
- Bug 1218405 - Change Loop's standalone background for the visual refresh/latest designs
- Bug 1218450 - The width of the tile shown on Loop's standalone when you're the only person in the room is wrong, giving a bad layout.
- Update L10n
(Reporter)

Comment 1

2 years ago
Regarding the CSP items from bug 1139119, I think we could ship this at the same times as the report-only CSP, hence saving two releases.


Richard: Also note that this release includes bug 1208466 / bug 1209078 which provide a different UI for the standalone if a user clicks the link to the room they own.
(Assignee)

Updated

2 years ago
Assignee: nobody → bobm
QA Contact: rpappalardo
Depends on: 1212095
will need to re-verify 0.20.0 config changes first to make sure nothing's broken, before deploying this release stage
(Reporter)

Comment 3

2 years ago
Just to note, although 0.21.0 is on staging, I've asked Bob to redeploy with the CSP in bug 1139119 comment 34 as that should be a more complete CSP and make checking the output easier.
(In reply to Mark Banner (:standard8) from comment #3)
> Just to note, although 0.21.0 is on staging, I've asked Bob to redeploy with
> the CSP in bug 1139119 comment 34 as that should be a more complete CSP and
> make checking the output easier.

Yea, I saw.  thanks, Mark!
(Assignee)

Comment 5

2 years ago
(In reply to Richard Pappalardo [:rpapa][:rpappalardo] from comment #4)
> (In reply to Mark Banner (:standard8) from comment #3)
> > Just to note, although 0.21.0 is on staging, I've asked Bob to redeploy with
> > the CSP in bug 1139119 comment 34 as that should be a more complete CSP and
> > make checking the output easier.
> 
> Yea, I saw.  thanks, Mark!

An updated 0.21.0 stack with the new CSP configuration has been deployed to stage.  Closing this bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
verifying re-deployed stack

----------------------------
HOST CHECKS (STAGE)
----------------------------

EC2 INSTANCE PROPERTIES
region: eu-west-1: 
id: i-3bac5982
tags["Type"]: loop_client
tags["AppGitRef"]: refs/tags/0.21.0
tags["Stack"]: loopclientstage1-loop-client-app-44
public_dns_name: ec2-52-17-192-92.eu-west-1.compute.amazonaws.com
launch_time: 2015-11-03T23:01:22.000Z


PROCESS CHECK

datadog, circus, heka, nginx --> Running!


$ curl -I https://call.stage.mozaws.net:
HTTP/1.1 301 Moved Permanently
Content-Length: 191
Content-Security-Policy-Report-Only: frame-ancestors 'self'; default-src 'self'; img-src 'self' data: https://www.gravatar.com/ https://www.google-analytics.com https://stats.g.doubleclick.net; font-src 'none'; frame-src 'self' https://tiles.cdn.mozilla.net; connect-src wss://*.tokbox.com https://*.opentok.com https://*.tokbox.com wss://*.mozilla.com https://*.mozilla.org wss://*.mozaws.net https://*.mozaws.net; media-src 'self' blob:; script-src 'self' 'unsafe-inline' 'unsafe-eval' https://cdn.optimizely.com https://www.google-analytics.com; style-src 'self' about: 'unsafe-inline'; report-uri /__cspreporting__/
Content-Type: text/html
Date: Tue, 03 Nov 2015 23:55:34 GMT
Location: https://www.mozilla.org/firefox/hello/
X-Frame-Options: SAMEORIGIN
Connection: keep-alive


----------------------------
URL CHECKS (STAGE)
----------------------------

https://call.stage.mozaws.net:
Request was redirected!
status code: 200 --> destination: https://www.mozilla.org/en-US/firefox/hello/

Response time: 0.129663


https://call.stage.mozaws.net/config.js:
var loop = loop || {};

loop.config = {
  serverUrl: 'https://loop.stage.mozaws.net/v0',
  feedbackApiUrl: 'https://input.allizom.org/api/v1/feedback',
  feedbackProductName: 'Loop',
  downloadFirefoxUrl: 'https://www.mozilla.org/firefox/new/?scene=2&utm_source=hello.firefox.com&utm_medium=referral&utm_campaign=non-webrtc-browser\#download-fx',
  privacyWebsiteUrl: 'https://www.mozilla.org/privacy/firefox-hello/',
  legalWebsiteUrl: 'https://www.mozilla.org/about/legal/terms/firefox-hello/',
  marketplaceUrl: 'https://marketplace-dev.allizom.org/iframe-install.html',
  learnMoreUrl: 'https://www.mozilla.org/hello/',
  roomsSupportUrl: 'https://support.mozilla.org/kb/group-conversations-firefox-hello-webrtc',
  guestSupportUrl: 'https://support.mozilla.org/kb/respond-firefox-hello-invitation-guest-mode',
  generalSupportUrl: 'https://support.mozilla.org/kb/respond-firefox-hello-invitation-guest-mode',
  unsupportedPlatformUrl: 'https://support.mozilla.org/kb/which-browsers-will-work-firefox-hello-video-chat',
  tilesIframeUrl: 'https://tiles.cdn.mozilla.net/iframe.html',
  tilesSupportUrl: 'https://support.mozilla.org/kb/tiles-firefox-hello',
  fxosApp: {
    name: 'Hello Stage',
    manifestUrl: 'https://marketplace-dev.allizom.org/app/ae2af828-21be-4483-ae94-476fe48c6cf8/manifest.webapp',
    rooms: false
  }
};

Response time: 0.644565


https://loop.stage.mozaws.net:
{
    "endpoint": "https://loop.stage.mozaws.net", 
    "name": "mozilla-loop-server", 
    "fakeTokBox": false, 
    "fxaOAuth": true, 
    "version": "0.19.1", 
    "i18n": {
        "defaultLang": "en-US"
    }, 
    "homepage": "https://github.com/mozilla-services/loop-server/", 
    "description": "The Mozilla Loop (WebRTC App) server"
}
Response time: 0.642174


https://loop.stage.mozaws.net/push-server-config:
{
    "pushServerURI": "wss://autopush.stage.mozaws.net"
}
Response time: 0.635863
------------------
SUMMARY (STAGE)
------------------

Placed several calls successfully between Dev Edition (44.0a2) and General Release (41.0.2 & 42.0) using new loop-client tag.


end-2-end test calls (shared URL) - OK
Video/audio mute/unmute - OK
messaging (from Nightly to Nighty) - OK 
Tab & window-sharing - OK
privacy & ToS links - OK
Feedback screens - OK

unit tests for 0.20.2 release - PASS

Verifying STAGE.
Status: RESOLVED → VERIFIED
Blocks: 1221353
You need to log in before you can comment on or make changes to this bug.