Closed Bug 1218658 Opened 6 years ago Closed 3 years ago

[Woodduck][System][Homescreen]Cannot return to homescreen when launching two Apps rapidly almost at the same time

Categories

(Firefox OS Graveyard :: Gaia::System::Task Manager, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-master unaffected)

RESOLVED WONTFIX
Tracking Status
b2g-master --- unaffected

People

(Reporter: binjian.tu.hz, Unassigned)

References

Details

Attachments

(2 files)

Description:
Cannot return to homescreen when launching two Apps rapidly almost at the same time.
No active App currently.
See the attachment to get more details.

Reproduce Steps (5%):
1. Try to launch two Apps at the same time rapidly (using two fingers pressing two Apps - Contacts and Camers)
2. Hold home button
3. Remove Contacts first and Camera last
4. Black Screen still -- KO (see index.png in attachment)
5. Press Home button to try to go back homescreen but still hold in black screen -- KO (see index.png in attachment)

Analysis:
1. No active App currently (see no-active-app.png)
2. See the logs in console (see console.log and console.log.png)
Can we get a video?
Keywords: qawanted
Just to make sure: this is 2.5 on an aries device?
Flags: needinfo?(binjian.tu.hz)
We found the issue on Woodduck branch.
The vedio will be updated by wei.deng.
He'll release a download link.
Flags: needinfo?(binjian.tu.hz) → needinfo?(wei.deng)
Summary: [System][Homescreen]Cannot return to homescreen when launching two Apps rapidly almost at the same time → [Woodduck][System][Homescreen]Cannot return to homescreen when launching two Apps rapidly almost at the same time
Here is the video download link:
http://pan.baidu.com/s/1bnlvXsb
Flags: needinfo?(wei.deng) → needinfo?(anygregor)
Hi Etienne:

Sorry for bothering again, but do you think you'll be suitable to help chech the log here, from Gaia system point of view? Or suggest me a right person?

Thanks!
Assignee: wehuang → nobody
Flags: needinfo?(etienne)
QA Contact: wehuang
Thats the old homescreen. Kevin, can you take a look?
Flags: needinfo?(anygregor) → needinfo?(kevingrandon)
(In reply to Wesly Huang (TAM) from comment #5)
> Hi Etienne:
> 
> Sorry for bothering again, but do you think you'll be suitable to help chech
> the log here, from Gaia system point of view? Or suggest me a right person?

It's hard to check the logs since I don't have the code where the debug statements were added :)

* I don't think this is homescreen-related, even when we get to webapps-launch at the same time the WindowManager should do the right thing and open both apps one after the other. And couldn't find a regression in this area.
* Even if something goes wrong and there's no active app pressing "home" should work and display the homescreen
* Might be an issue with the old TaskManager, can we reproduce this on master?
Flags: needinfo?(etienne)
BTW, It took me about 2 hours to reproduce the issue in order to take down the video.
For our PA, 5% reproduce.
If you want to check where the log/debug statements were added, you can ask Wesly for a Woodduck SW to have a check since we've sent him 2 days ago.
(In reply to Gregor Wagner [:gwagner] from comment #7)
> Thats the old homescreen. Kevin, can you take a look?

This is most certainly a problem with the system app and the not the home screen. The home screen just requests opening of apps.

Like Etienne said, let's see if we can reproduce this issue on master.
Flags: needinfo?(kevingrandon)
The similar race condition issue:
https://bugzilla.mozilla.org/show_bug.cgi?id=1220028
(Thanks Etienne and Kevin's comment!)

Hi Norry:

This issue was found in woodduck w/ 5% repro. rate per partner (MTK build), but we are more interested in knowing if this can be seen in master per comment#8 & comment#10 as above, would you help verify? 

Thanks!
Flags: needinfo?(fan.luo)
Keywords: qawanted
Hi Wesly,
This bug can't be repo on flame master & Aries Master with 100 attempts on each device(flame/aries). It can return to home screen successfully based on the STR of comment 0. Please see video: Arieskk_master.3gp
Rate: 0/100

FlameKK master 512MB(Unaffected)
Build ID               20151101150206
Gaia Revision          91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gaia Date              2015-10-28 20:32:15
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/96377bdbcdf3e444a22aeaa677da696243b00d98
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151101.183234
Firmware Date          Sun Nov  1 18:32:48 EST 2015
Bootloader             L1TC000118D0

AriesKK master(Unaffected)
Aries KK eng
Build ID               20151101012023
Gaia Revision          91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gaia Date              2015-10-28 20:32:15
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/96377bdbcdf3e444a22aeaa677da696243b00d98
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151101.004008
Firmware Date          Sun Nov  1 00:40:17 UTC 2015
Bootloader             s1
Flags: needinfo?(fan.luo) → needinfo?(wehuang)
Keywords: qawanted
Thanks ZouYi's effort on it!

Then given master's result, the late phase of 2.0/2.0m, and the STR in comment 0, we'll lower down this issue's priority until new input.
Flags: needinfo?(wehuang)
Blocks: Woodduck
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.