New Tab button on search widget doesn't open a new tab

RESOLVED DUPLICATE of bug 1179519

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1179519
2 years ago
2 years ago

People

(Reporter: justdave, Unassigned)

Tracking

Trunk
All
Android
Points:
---

Firefox Tracking Flags

(firefox41 unaffected, firefox42 unaffected, firefox43 unaffected, firefox44 affected, fennec44+)

Details

Running current nightly, it updated earlier today.  Been noticing this for about the last week or so (may have been around longer than that, I haven't really paid attention).

I don't see a widgets component, not sure where this would best fit otherwise, so feel free to move it.

The Search widget for the home screen provided by Nightly has three buttons on it, one has the app icon and launches the app, restoring however it was when you last ran it, one opens a search dialog, and one is labeled "+ New Tab".

The "+ New Tab" button does the same thing as the app icon button, and simply launches the app, it doesn't open a new tab.  I wind up with whatever tab in front that was last visible when the app ran previously, and still have to go into the tab panel and hit new tab from there.
tracking-fennec: --- → ?
status-firefox41: --- → unaffected
status-firefox42: --- → unaffected
status-firefox43: --- → unaffected
Hardware: ARM → All

Comment 1

2 years ago
This works for my on Nightly on my Nexus 4.

Dave, what Android device/version are you running, and do you still see this?
tracking-fennec: ? → 44+
Flags: needinfo?(justdave)
Samsung Galaxy S4, Android 4.4.2, Verizon

I can still replicate this with current nightly in both Touchwiz and Apex.
Flags: needinfo?(justdave)
Some additional reproduction notes now that I've been paying more attention to it...
If the app is loaded in active memory, the New Tab button works fine. If the app has been backgrounded, and has to be restored, then it does not work (it opens the app but does not go to the new tab screen).
You can reproduce this at will on my device by going into the app switcher screen and force-quitting Nightly, then hit the New Tab button on the widget.
Is this really a regression? The STR are the exact same as a bug I filed in July. bug 1179519
Nope, I'll go with your bug.  Like I said, I only just noticed, it, haven't been paying attention enough to notice how long it's been like that.  For whatever reason Bugzilla's dupe detection never showed me that one when I filed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1179519
You need to log in before you can comment on or make changes to this bug.