[RTL][Status bar]Status bar is right-aligned.

VERIFIED FIXED

Status

P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: qiutian, Assigned: apastor)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [2.5-rtl-test-run][systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8679357 [details]
Status_right.png

[1.Description]:
[RTL][Arieskk_v2.5][Status bar]Set your phone language to Arabic and observe, Status bar is align right.
See attachment: Status_right.png

[2.Testing Steps]: 
1. Set your phone language to Arabic.
2. Observe the status bar.

[3.Expected Result]: 
In step 2, Status bar should be left-aligned.

[4.Actual Result]: 
In step 2, Status bar is right-aligned.

[5.Reproduction build]: 
Device: AriesKK_2.5 [Affected]
Build ID               20151026223015
Gaia Revision          b564b21e08ffc3e4962f08850843c7482932ee7b
Gaia Date              2015-10-26 14:22:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6c7c983bce46a460c2766fbdd73283f6d2b03a69
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151026.214940
Firmware Date          Mon Oct 26 21:49:48 UTC 2015
Bootloader             s1

Device: FlameKK_v2.5[Unaffected]
Build ID               20151026030217
Gaia Revision          a677ddd3aa3a81058775938bd56008d96dbc78b0
Gaia Date              2015-10-26 04:48:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5ca03a00d26823ce91ee0eaa2937bed605bd53c1
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151026.070911
Firmware Date          Mon Oct 26 07:09:23 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

3 years ago
QA Whiteboard: rtl-impact
(Reporter)

Updated

3 years ago
status-b2g-master: --- → affected
Whiteboard: [2.5-rtl-test-run] → [2.5-rtl-test-run][systemsfe]
Alberto, did this come from bug 1179723?
Flags: needinfo?(apastor)
(Assignee)

Comment 2

3 years ago
Yes, probably. It should have an easy fix, though. I'll take a look, thanks!
Flags: needinfo?(apastor)
(Assignee)

Updated

3 years ago
Assignee: nobody → apastor
Created attachment 8679955 [details] [review]
[gaia] albertopq:1218720-rtl-statusbar > mozilla-b2g:master
(Assignee)

Comment 4

3 years ago
Comment on attachment 8679955 [details] [review]
[gaia] albertopq:1218720-rtl-statusbar > mozilla-b2g:master

Guillaume, would you take a look? Thanks!
Attachment #8679955 - Flags: review?(gmarty)
Hey Alberto,

Thanks for taking care of this! Since I'm on the team doing RTL for 2.5, I allowed myself some comment on your PR. Cheers!
Flags: needinfo?(apastor)
(Assignee)

Comment 6

3 years ago
Thank you for the tips and the read! Much better now :) Please, take a look again and feel free to leave feedback. Thanks!
Flags: needinfo?(apastor)

Updated

3 years ago
Priority: -- → P1
(Assignee)

Updated

3 years ago
Attachment #8679955 - Flags: feedback?(augustin.trancart)
Attachment #8679955 - Flags: feedback?(augustin.trancart) → feedback?(augustin.trancart)
Comment on attachment 8679955 [details] [review]
[gaia] albertopq:1218720-rtl-statusbar > mozilla-b2g:master

Looks good to me, thanks!
Attachment #8679955 - Flags: feedback?(augustin.trancart) → feedback+
Comment on attachment 8679955 [details] [review]
[gaia] albertopq:1218720-rtl-statusbar > mozilla-b2g:master

Looks good to me too!
Attachment #8679955 - Flags: review?(gmarty) → review+
(Assignee)

Comment 9

3 years ago
master: https://github.com/mozilla-b2g/gaia/commit/cd719553319016647ead8384d6da12c36eeed65d
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
blocking-b2g: --- → 2.5+
Created attachment 8682367 [details]
Status bar_master.png

This bug has been verified as pass on latest build of Flame KK master and Aries KK master  by the STR in comment 0.
Actual results: Status bar is left-aligned.
See attachment: Status bar_master.png
Reproduce rate: 0/10.

Device: Flame KK master512MB (Pass)
Build ID               20151102150204
Gaia Revision          7954ff0cbd794a35499a1082bed273598f82ee6f
Gaia Date              2015-11-02 17:35:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6275cd9c71b76891f6b6585dabc687bc443ab877
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151102.182914
Firmware Date          Mon Nov  2 18:29:28 EST 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK master (Pass)
Build ID               20151103000930
Gaia Revision          7954ff0cbd794a35499a1082bed273598f82ee6f
Gaia Date              2015-11-02 17:35:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9f69202d82752e093a653a8f15b0274e347db33a
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151102.233051
Firmware Date          Mon Nov  2 23:30:58 UTC 2015
Bootloader             s1
QA Whiteboard: rtl-impact → rtl-impact[MGSEI-Triage+]
status-b2g-v2.5: --- → affected
status-b2g-master: affected → verified
(Reporter)

Comment 11

3 years ago
This bug has been verified as pass on latest build of Flame KK 2.5 512mb and Aries KK 2.5 by the STR in comment 0.

Actual results: Status bar is left-aligned.
See attachment: Verified_Aries_KK_v2.5_Status.png
Reproduce rate: 0/10.

Device: Aries KK 2.5(Pass)
Build ID               20151107112205
Gaia Revision          577948202ae12154524a2bd2bd6d467838ad50b8
Gaia Date              2015-11-07 10:00:59
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/ae7b8b1fd9e1504347b938820f99d75058049386
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151107.104119
Firmware Date          Sat Nov  7 10:41:27 UTC 2015
Bootloader             s1

Device: Flame KK 2.5 512MB(Pass)
Build ID               20151108004501
Gaia Revision          577948202ae12154524a2bd2bd6d467838ad50b8
Gaia Date              2015-11-07 10:00:59
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/ae7b8b1fd9e1504347b938820f99d75058049386
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151108.045623
Firmware Date          Sun Nov  8 04:56:35 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
(Reporter)

Comment 12

3 years ago
Created attachment 8684766 [details]
Verified_Aries_KK_v2.5_Status.png
(Reporter)

Updated

3 years ago
status-b2g-v2.5: affected → verified
You need to log in before you can comment on or make changes to this bug.