After clearing browser history, pages still available/shown as results in search bar

RESOLVED DUPLICATE of bug 1216394

Status

Firefox OS
Gaia::Search
RESOLVED DUPLICATE of bug 1216394
3 years ago
3 years ago

People

(Reporter: aryx, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+)

Details

(Whiteboard: [systemsfe])

B2G 2.5 20151026150341 on Flame (v18D_nightly_v4 base image)

After I cleared the browsing history from Settings > Browsing Privacy (browser windows already killed before in the task manager), typing letters in the global search bar still shows the urls. The issue persists after a restart, Firefox Accounts/Sync hasn't been configured on the device.

From the log:
  2287  2287 W Settings: [JavaScript Warning: "Property contained reference to invalid variable.  Error in parsing value for 'color'.  Falling back to 'inherit'." {file: "app://settings.gaiamobile.org/shared/elements/gaia_switch/style.css" line: 14 column: 212 source: " var(--label-color)"}]
   212   212 I GeckoConsole: Content JS LOG: Browsing history successfully cleared. 
   212   212 I GeckoConsole:     at .clearHistory/</</</</< (app://system.gaiamobile.org/js/places.js:417:21)
   212   212 E GeckoConsole: [JavaScript Error: "ConstraintError" {file: "jar:file:///system/b2g/omni.ja!/components/DataStoreImpl.js" line: 233}]
   212   212 I Gecko   : XXX FIXME : Dispatch a mozChromeEvent: inputmethod-contextchange
Whiteboard: [systemsfe]
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
blocking-b2g: 2.5? → 2.5+
Let's get a regression window.
Keywords: regressionwindow-wanted
It's likely a dupe of Bug 1216394 since this one was opened before the other lands.
Can you try again now on the latest master (making sure it has https://github.com/mozilla-b2g/gaia/commit/1c9bec1837676093fdef074bdc2d6de0a83c0238) and see if it reproduces?
Flags: needinfo?(aryx.bugmail)
Thanks, works now as expected with B2G 2.5 20151027150240 (Gaia a26eadc5).
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(aryx.bugmail)
Resolution: --- → DUPLICATE
Duplicate of bug: 1216394
Per comment 3 and comment 4, this bug has fixed, and the keywords "regressionwindow-wanted" is no longer needed. so I clear it.
Keywords: regressionwindow-wanted → regression
You need to log in before you can comment on or make changes to this bug.