Number buttons are taller and have the number shifted to the left when two SIMs are present

RESOLVED FIXED

Status

Firefox OS
Gaia::Contacts
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: gsvelto, Assigned: gsvelto)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 8679523 [details]
Screenshot with bot issues highlighted

When two SIMs are present the number button in a contact page shows the default SIM indicator on the right with three dots below it. However this also causes the button to be taller by 0.2rem than it should be and the number is shifted to the left by 0.4rem so it's not aligned any more with the phone type string that's just above it.

I've attached a side-by-side screenshot with the two issues highlighted.
Also this is particularly jarring when opening a contact because there's a delay before the SIM indicator is shown and you can literally see the button "change" after a fraction of a second that you've opened the contact.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Created attachment 8715238 [details] [review]
[gaia] gabrielesvelto:bug-1218868-contacts-button-alignment-fix > mozilla-b2g:master
Comment on attachment 8715238 [details] [review]
[gaia] gabrielesvelto:bug-1218868-contacts-button-alignment-fix > mozilla-b2g:master

This patch is doing something slightly different than I had anticipated. Besides adjusting the button height so it's consistently 4rem in height I've removed the rules that aligned the number so that it would start 1.5rem from the left and let it use the 1.2rem padding that all others buttons use. This way the contents of the number button are aligned to the contents of all the other buttons (and they're not different between the single-SIM and multi-SIM case).

This was also tested in RTL mode and works correctly there too.
Attachment #8715238 - Flags: review?(francisco)
Comment on attachment 8715238 [details] [review]
[gaia] gabrielesvelto:bug-1218868-contacts-button-alignment-fix > mozilla-b2g:master

lgtm, thanks Gabriele!
Attachment #8715238 - Flags: review?(francisco) → review+
Thanks for the review Francisco! Merged to gaia/master 9261ed36b29d6012d5866ee08e533feb5bfa0a57

https://github.com/mozilla-b2g/gaia/commit/9261ed36b29d6012d5866ee08e533feb5bfa0a57
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.