Closed Bug 1218946 Opened 4 years ago Closed 4 years ago

Status bar is white on the tutorial pages after an OTA

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

RESOLVED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- fixed
b2g-master --- fixed

People

(Reporter: KTucker, Assigned: mikehenrty)

Details

(Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe])

Attachments

(4 files)

After an OTA, the user will notice that the status bar is white on the tutorial pages. During the regular FTU, the status bar appears to be dark gray or black.

Repro Steps:
1) Flash an Aries to RC4 build 20150619225606 
2) Proceed through the FTU, paying close attention to the status bar color during the tutorial. 
3) OTA to the latest build. 
4) Pay close attention to the status bar on the tutorial screens after installing the update.

Actual:
The status bar is white on the tutorial pages after performing an OTA.

Expected:
The status bar appears dark gray or black in color on the tutorial pages.

Environmental Variables:
Device: Aries 2.5
Build ID: 20151027122943
Gaia: b6ede3d0fdec5fc922e9ca3401e60db461bf705c
Gecko: 9a8f2342fb3116d23989087e026448d38a3768c5
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 5/5 100%
See attached: Screenshots, logcat
Attached image RegularFTU.png
Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe]
This issue did not occur on the Flame 2.5 but no tutorial pages were shown after an OTA.

Device: Flame 2.5 (512mb)(KK)
BuildID: 20150527010201
Gaia: 8ca93673869a64e09ed6153c5402896822dfb253
Gecko: ff2e07228041
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
(In reply to KTucker [:KTucker] from comment #3)
> This issue did not occur on the Flame 2.5 but no tutorial pages were shown
> after an OTA.

That is bug 1217620. Its now fixed on master, but will no doubt complicate OTA testing :(
Blocks: 1218983
No longer blocks: 1218983
Alison should we block on this issue?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(ashiue)
[Blocking Requested - why for this release]:
Bad user experience for white status bar in FTU
blocking-b2g: --- → 2.5?
Flags: needinfo?(ashiue)
blocking-b2g: 2.5? → 2.5+
Assignee: nobody → mhenretty
Comment on attachment 8680559 [details] [review]
[gaia] mikehenrty:bug-1218946-dark-theme-tutorial > mozilla-b2g:master

AFAICT, the theme color was never set for upgrade tutorial scenarios. So I added a marionette test for this.

Sam, wanna have a look?
Attachment #8680559 - Flags: review?(sfoster)
Priority: -- → P2
Comment on attachment 8680559 [details] [review]
[gaia] mikehenrty:bug-1218946-dark-theme-tutorial > mozilla-b2g:master

Ah I see, good catch, thanks!
Attachment #8680559 - Flags: review?(sfoster) → review+
Merged to master: https://github.com/mozilla-b2g/gaia/commit/67b15c373527924e5f7b050251b2f3050f31b92d
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8680559 [details] [review]
[gaia] mikehenrty:bug-1218946-dark-theme-tutorial > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): n/a
[User impact] if declined: Status bar color mismatch in FTU tutorial when upgrading to 2.5
[Testing completed]: On device by author and reviewer
[Risk to taking this patch] (and alternatives if risky): V. low risk, 1-liner polish bug confined to FTU app
[String changes made]: None
Attachment #8680559 - Flags: approval-gaia-v2.5?
Comment on attachment 8680559 [details] [review]
[gaia] mikehenrty:bug-1218946-dark-theme-tutorial > mozilla-b2g:master

This landed in 2.5. Updating approval flag

Thanks
Attachment #8680559 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
(In reply to Mahendra Potharaju [:mahe] from comment #12)
> Comment on attachment 8680559 [details] [review]
> [gaia] mikehenrty:bug-1218946-dark-theme-tutorial > mozilla-b2g:master
> 
> This landed in 2.5. Updating approval flag
> 
> Thanks

updating flag :)
You need to log in before you can comment on or make changes to this bug.