Scroll horizontally on mouse wheel if no vertical scrollbar

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
17 years ago
14 years ago

People

(Reporter: wemoloh, Assigned: bryner)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226
BuildID:    2001122617

It would be nice if the browser window scrolled horizontally when you use the
mouse wheel and there is a horizontal scrollbar but no vertical scrollbar (i.e.
the page is wide but not tall).  I believe this is the behavior of Explorer in
Windows.

Reproducible: Always
Steps to Reproduce:
1. Open a Composer window
2. Type a continuous line of characters past the right edge of the window
3. Scroll up with the mousewheel

Actual Results:  Nothing happens.

Expected Results:  Scroll the page to the left.
*** Bug 121887 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
-> bryner, future
Assignee: jaggernaut → bryner
Target Milestone: --- → Future

Comment 3

17 years ago
This could be confusing during page load, or any situation when content changes
toggle the scrollbar visibility while the user is already scrolling.  Perhaps
this could be disabled during page load, or delayed if we are already inside a
wheel-scrolling event?

Comment 4

17 years ago
I suspect this would be more confusing than expected (would we change
pageUp/pageDown to work like that too?), and should be wontfix.

Comment 5

17 years ago
um, could it be an option that defaults to off, then? I don't think that just
because some people wouldn't want it it shouldn't be implemented at all.
(Assignee)

Comment 6

17 years ago
I don't buy that windows explorer doing this is relevant.  It's a file manager.
 We're a web browser.  I'd prefer not to fill the app with obscure options that
very few people use.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 7

17 years ago
I don't think that windows explorer does it is relevant either, but try going to
http://pc.kano.net/in2/not/funny/airplane.jpg and prepare to be annoyed. it
would just be a nice feature. (personally I think the attitude that useful
features should be abandoned if few people will use them isn't in the spirit of
mozilla, but do what you please.)
*** Bug 246256 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.