Closed Bug 1218992 Opened 4 years ago Closed 4 years ago

Move code for decisioning to remote page

Categories

(Firefox :: New Tab Page, defect)

40 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1218998
Iteration:
44.3 - Nov 2

People

(Reporter: oyiptong, Assigned: oyiptong)

References

(Blocks 1 open bug, )

Details

Most of RemoteNewTabUtils and all of DirectoryLinksProvider goes away in favor of raw calls from PlacesProvider, PrefsHandler, etc
Assignee: nobody → oyiptong
Summary: Move decisioning in remote page → Move decisioning to remote page
Duplicate of this bug: 1220233
This bug removes unnecessary messages from RemoteAboutNewTab and ensures there are tests for the existing ones.
Summary: Move decisioning to remote page → Move code for decisioning to remote page
Closing this bug as duplicate of bug 1218998. Since we are implementing the API's ahead of schedule, we can decide which API's are getting through, and remove the unused code.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: newtab-web-apis
You need to log in before you can comment on or make changes to this bug.