Closed Bug 1219120 Opened 9 years ago Closed 8 years ago

NSec package's IndexedDB is not isolated

Categories

(Firefox OS Graveyard :: Infrastructure, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: mlien, Unassigned)

References

Details

[Description]
Navigate to two packages and use their IndexedDB, it won't isolated

[Reproduce Steps]
1. Enable two preferences "network.http.enable-packaged-apps" and "network.http.signed-packages.enabled"
2. Set "network.http.signed-packages.trusted-root" to "http://people.mozilla.org/~mlien/"
3. Navigate to "http://people.mozilla.org/~mlien/nsec/indexed-db-web-1/i1.pak!//index.html" in Browser app
4. Add any item
5. Navigate to another package "http://people.mozilla.org/~mlien/nsec/indexed-db-web-2/i2.pak!//index.html"

[Expected Result]
Two packages should have different result

[Actual Result]
Two packages have the same result

[Build Information]
Build ID               20151027221526
Gaia Revision          a26eadc5e1133d5112b6cbc10badbb7670a1090f
Gaia Date              2015-10-27 17:36:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2b333a1d94e805a59c619ee41a6dec7fdcce505d
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151027.213419
Firmware Date          Tue Oct 27 21:34:27 UTC 2015
Bootloader             s1

[Reproduce Rate]
100%
QA Whiteboard: [COM=NSec]
Depends on: 1178526, 1195930
This test is probably relevant  to OA but Im closing this since its an nsec bug.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.