[FFOS2.0][Woodduck][System]The url in homescreen iframe is added by timestamp

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
8 months ago

People

(Reporter: wenjie.chen.hz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8679830 [details]
woodduckbug.png

Dear Mozilla:
  please see the atachement.
  In homescreen, if press home key,the url in iframe will grew.Cause this effect codes:
   gaia/apps/system/js/homescreen_window.js 176:
     HomescreenWindow.prototype.ensure = function hw_ensure(reset) {
    this.debug('ensuring homescreen...', this.frontWindow);
    if (!this.element) {
      this.render();
    } else if (reset) {
      if (this.frontWindow) {
        // Just kill front window but not switch to the first page.
        this.frontWindow.kill();
      } else {
        this.browser.element.src = this.browser_config.url + Date.now();
      }
    }

    return this.element;
  };
========================================
this.browser.element.src = this.browser_config.url + Date.now();
======================================
above code cause it.

so I modify it to:
/////////////////////////
this.browser.element.src = this.url + Date.now();
//////////////////////////
Is there any risk?

Comment 1

3 years ago
Wesly,
would you please help to support this?
thanks.
Flags: needinfo?(wehuang)

Comment 2

3 years ago
Please arrange some engineers to analyze the issue.
In addition, if we take the patch above, no frozen issues such as
https://bugzilla.mozilla.org/show_bug.cgi?id=1217725
any more reported from our PA team.

Could someone tell me something about this?

Comment 3

3 years ago
Hi Etienne:

Do you think it's possible for you to give some suggestion to our partner TCL's patch above, from Gaia:system point of view? Or actually this is unrelated to Gaia:system so you probably can point us a proper module?

Thanks!
Flags: needinfo?(wehuang) → needinfo?(etienne)

Updated

3 years ago
Assignee: wehuang → nobody
QA Contact: wehuang
See Also: → bug 1217725

Updated

3 years ago
Blocks: 1218285
I think this is a dupe of bug 1079699.
My strong suggestion is to take the patch from bug 1079699, it comes with a test :)
Flags: needinfo?(etienne)

Updated

3 years ago
Blocks: 1054172

Comment 5

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.