Firefox 42.0b99 Intermittent crash when loading YouTube video in an iframe

REOPENED
Unassigned

Status

()

Core
Graphics
P3
normal
REOPENED
2 years ago
4 months ago

People

(Reporter: agibson, Unassigned)

Tracking

42 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(platform-rel -, firefox47 affected, firefox48 affected, firefox49 affected, firefox-esr45 affected, firefox50 affected, firefox51 affected, firefox52 wontfix, firefox54 affected)

Details

(Whiteboard: [platform-rel-Youtube][gfx-noted], crash signature)

(Reporter)

Description

2 years ago
"Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:42.0) Gecko/20100101 Firefox/42.0"

We picked up this crash through when writing some automated Selenium tests, and can also reproduce it manually.

STR in Firefox 42.0b99:

1.) Visit the URL https://www.mozilla.org/en-US/firefox/developer/
2.) Scroll down and click on the video thumbnail entitled "Page Inspector"

Expected results:

A modal opens and the YouTube video plays in an iframe.

Actual results:

The modal opens and then Firefox crashes.

The crash seems to happen intermittently, about once every 10-20 attempts. Just keep hard refreshing and trying again.

This is the crash report I received: https://crash-stats.mozilla.com/report/index/a575f69a-d342-42ef-bae6-92f652151028

Updated

2 years ago
platform-rel: --- → ?

Updated

2 years ago
Whiteboard: [platform-rel-Youtube]
Anthony, can you take a look from a graphics standpoint?

(- on the partner thing because we haven't seen this crash in a while)
platform-rel: ? → -
Component: General → Graphics
Flags: needinfo?(anthony.s.hughes)
Product: Firefox → Core
Does not reproduce for me on MacOS 10.11 but there are also 0 crash reports for this on MacOS 10.11. This seems to be happening exclusively on MacOS 10.10 and earlier with Firefox and Thunderbird 48.0 and earlier. There are no strong correlations to graphics gpus as far as I can tell.

Youtube may be a red herring in this case as it only shows up in 2.3% of all crash reports from the last week.

It would be good to see if Alex can still reproduce this and provide debugging info.
Crash Signature: [@ __pthread_kill]
Flags: needinfo?(anthony.s.hughes) → needinfo?(agibson)
OS: Unspecified → Mac OS X
Whiteboard: [platform-rel-Youtube] → [platform-rel-Youtube][gfx-noted]
(Reporter)

Comment 3

a year ago
I no longer seem to be able to reproduce this crash.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(agibson)
Resolution: --- → WORKSFORME
Crash volume for signature '__pthread_kill':
 - nightly (version 50): 1 crash from 2016-06-06.
 - aurora  (version 49): 1 crash from 2016-06-07.
 - beta    (version 48): 160 crashes from 2016-06-06.
 - release (version 47): 3886 crashes from 2016-05-31.
 - esr     (version 45): 335 crashes from 2016-04-07.

Crash volume on the last weeks:
             Week N-1   Week N-2   Week N-3   Week N-4   Week N-5   Week N-6   Week N-7
 - nightly          0          0          0          0          0          0          1
 - aurora           0          0          0          1          0          0          0
 - beta            24         28         30         25         30         12          8
 - release        593        605        599        542        592        567        150
 - esr             45         44         37         35         31         31         28

Affected platform: Mac OS X
status-firefox47: --- → affected
status-firefox48: --- → affected
status-firefox49: --- → affected
status-firefox50: --- → affected
status-firefox-esr45: --- → affected
As it is the top crash #4 on beta 49, I don't think we should close it.
Status: RESOLVED → VERIFIED
Reopening based on Comment 5.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
This is happening very often on OS X 10.7 (more than 95% compared to less than 70% for OS X crashes overall), but only with build ID 20160802125837.

Let's leave it open to reassess, but I think it has been fixed by something landed on the build after 20160802125837l.
You can see the correlation with 10.7 from https://mozilla.github.io/stab-crashes/correlations.html?channel=beta&signature=__pthread_kill .  But, why are people on 10.7 updating to beta 49 at all, when in theory we have desupported OS X 10.6-10.8?   We have 3000+ crashes in the last week on 49.0b1, that shouldn't be there, because those users shouldn't have updated to 49.
In total, in the last week, we've had 2452 crash reports from OS X 10.7 on 49.0b: https://crash-stats.mozilla.com/search/?product=Firefox&version=49.0b&_sort=-date&_facets=signature&_facets=platform_pretty_version&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#facet-platform_pretty_version
Most of the crashes (2381) on 49.0b with OS X 10.7 are due to this signature.
I've seen this crash twice today on 10.11.6 with Firefox 48.0.1

https://crash-stats.mozilla.com/report/index/f89c808e-40e4-4cad-a35e-9678a2160914
https://crash-stats.mozilla.com/report/index/f3baafc5-03b6-47d6-86d2-efab22160914
Crash volume for signature '__pthread_kill':
 - nightly (version 54): 0 crashes from 2017-01-23.
 - aurora  (version 53): 0 crashes from 2017-01-23.
 - beta    (version 52): 0 crashes from 2017-01-23.
 - release (version 51): 23 crashes from 2017-01-16.
 - esr     (version 45): 3463 crashes from 2016-08-03.

Crash volume on the last weeks (Week N is from 01-30 to 02-05):
            W. N-1  W. N-2  W. N-3  W. N-4  W. N-5  W. N-6  W. N-7
 - nightly       0
 - aurora        0
 - beta          0
 - release       9       0
 - esr         114     114     116     123     103     120     151

Affected platform: Mac OS X

Crash rank on the last 7 days:
           Browser   Content   Plugin
 - nightly
 - aurora
 - beta
 - release #862
 - esr     #95
status-firefox51: --- → affected
Crash volume for signature '__pthread_kill':
 - nightly (version 54): 2 crashes from 2017-01-23.
 - aurora  (version 53): 0 crashes from 2017-01-23.
 - beta    (version 52): 21 crashes from 2017-01-23.
 - release (version 51): 71 crashes from 2017-01-16.
 - esr     (version 45): 3601 crashes from 2016-08-10.

Crash volume on the last weeks (Week N is from 02-06 to 02-12):
            W. N-1  W. N-2  W. N-3  W. N-4  W. N-5  W. N-6  W. N-7
 - nightly       2       0
 - aurora        0       0
 - beta         16       0
 - release      43       9       0
 - esr         136     114     114     116     123     103     120

Affected platform: Mac OS X

Crash rank on the last 7 days:
           Browser   Content   Plugin
 - nightly #518
 - aurora
 - beta    #916
 - release #802
 - esr     #96
status-firefox52: --- → affected
status-firefox54: --- → affected
Mass wontfix for bugs affecting firefox 52.
status-firefox52: affected → wontfix
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.