Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 11944
20 years ago
20 years ago

People

(Reporter: dbaron, Assigned: karnaze)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

DESCRIPTION:  Modification of table cells through the DOM results in their
positions shifting vertically by a few pixels.

STEPS TO REPRODUCE:  Download the four when-com.* files in
http://www.fas.harvard.edu/~dbaron/nstmp/M9-3/ .  Load them in viewer (or
apprunner, or the sidebar...)  Click on some of the tabs at the bottom.  For
example, click "Date", then "List", then "Date" again.

ACTUAL RESULTS:  As you click on the tabs (which are table cells), you will see
their positions move up and down by a few pixels at various times.  I don't
understand exactly why it happens.

EXPECTED RESULTS: No dancing.

BUILDS TESTED:
 * Linux, apprunner, 1999-08-16-08-M9
 * Linux, viewer, 1999-08-16-08-M9
 * other Linux builds and (I think??) Windows ones.

ADDITIONAL INFORMATION:
I think the JS file in the example contains a workaround that slightly reduces
the effects of this bug.  Thus, let me verify it after taking that workaround
out, too.

I suspect that this bug may be the same thing as what happens in bug 11944.
However, I'm not sure and would thus like to track it as a separate issue.
However, I will mark bug 11944 as a dependency.
Depends on: 11944

Comment 1

20 years ago
Does this happen with Win and Mac?
This looks fixed in 1999-08-24-09-M10 Win95 apprunner.  I suspect it's fixed
completely now, since 11944 is fixed.  I'll double-check on Linux.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
This looks fixed on Linux.  Marking duplicate of 11944.

*** This bug has been marked as a duplicate of 11944 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 4

20 years ago
Verifying bug dup of 11944
You need to log in before you can comment on or make changes to this bug.