find "matches" text not working correctly with PDFs

RESOLVED DUPLICATE of bug 1062025

Status

()

RESOLVED DUPLICATE of bug 1062025
3 years ago
3 years ago

People

(Reporter: blozzephuo, Unassigned)

Tracking

41 Branch
Unspecified
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Here are some sample results:

http://www.mcarthurcounselingcenter.com/borderline.pdf
if I pull up find and type in "border", the text shows as "12 of 12 matches" ... if I click the next button, it still says "12 of 12 matches" ... if I click next again, it changes to "23 of 23 matches"

http://www.pdf995.com/samples/pdf.pdf
if I pull up find at type in "pdf", there is no text indicating the number of matches at all!

Expected behavior:
1) user presses Ctrl-f
2) user types their search phrase
3) to the right of the "Highlight All" and "Match Case" buttons, text such as the following should appear: "1 of 63 matches"
4) user presses the button to find the next occurrence of the phrase, the text is changed to "2 of 63 matches", etc.

This works correctly on HTML pages, but on PDFs rendered in pdf.js, the results are inconsistent.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Untriaged → PDF Viewer
Resolution: --- → DUPLICATE
Duplicate of bug: 1062025
You need to log in before you can comment on or make changes to this bug.